chan_oss.c:585 setformat: Unable to re-open DSP device /dev/

New asterisk user just trying out all of the demos. Everything seems to be working; I can call the demo extension #2 and I can call the digium demo extension via IAX and I can call other sip phones registered to the asterisk proxy. What I can’t do is get the voicemail demo to work (extension 1234). I get the error above, over and over and over again (device is actually /dev/dsp but the subject line cuts that off). The error goes on to say that the device does not exist, but it does. I’ve tried changing ownership and permissions on the file. It was owned by root:audio with permissions of 660 now it is owned by asterisk:asterisk with no effect. I’ve tried changing perms to 777, also with no effect. I looked at the code and it appears that it is a file descriptor issue (I am not a C programmer, so I am guessing at that). There is literally nothing else running on this machine except asterisk. It is version 1.2.10 running on Debian Sarge with a 2.6.8 kernel. It was not installed from the debian packages, but installed from scratch.

I am sure that I am missing something simple.

Thanks for your time.

Craig Russell

unless you want * to use your sound card, you dont need it to load OSS at all. in /etc/asterisk/modules.conf make sure that noload => is NOT commented, adn also make sure that the chan_alsa one is also not commented.

hope that helps

Thanks for that tip. That did the trick. If oss is not recommended why is it the default? Just out of curiosity.

its not ‘the default’ but it installs itself by default. It has its uses, they just aren’t always used.

glad that worked