Asterisk problem

good day to everyone, im still new in asterisk. i have a problem, after manual installation of asterisk 1.4 when i dial demo 500 i cant hear any voice,and an warning prompted chan_oss.c:686 setformat: unable to re-open DSP device /dev/dsp: No such file or directory. How can i solve this? i need your help. thank you so much

Best solution: install a SIP phone and forget about the console driver.

Otherwise you need to configure the sound card and the console driver.

thank you so much for the reply, i have to check it out on how to do it considering i am still new in asterisk through linux. Like how to configure the sound card and the console driver. Thank you so much, ill post it out the output after ill do what you said.

Using the sound card with Asterisk is not a normal thing to do and my basic configuration for sound was done as part of installing Linux for general use, several years ago. Consequently, I would probably have to start from first principles in setting up the sound card.

For that reason, and because support for the sound card is a very low priority for Asterisk developers, I would strongly suggest buying a SIP phone or installing a SIP soft-phone on a system on which you do understand how to configure the sound card.

If you want to continue with the Linux sound card support, you might want to know that there are two different driver standards.

The Asterisk console support is not really suitable for production use.

good day david55, thank you so much for your help, i really appreciate it. Your suggestion is the best solution when i try it having a SIP softphone, my problem is solved.Thank you so much for your help. These thread is considered as solved because of your help.