Chan_mobile and no audio


#1

Hello:
I am using Asterisk that is installed on the RasPBX distro for Raspberry Pi. I have followed various instructions I found on the Internet and have it set up for chan_mobile so that outbound and inbound calls are working from the cell phone and I can see it dial the number and also answer incoming calls correctly. So as far as I know the trunk and routes are set up correctly (in FreePBX interface that is also installed on this distro). But the problem is I cannot hear the person on the other end and they cannot hear me either, for outbound and inbound calls both. I am not sure what I can do to try and troubleshoot this further. I have tried using two different bluetooth adapters, and as mentioned tried Asterisk 13 and version 11 both, same issue happens with either. I’m guessing it should be a simple fix but if anybody has some ideas of things I can double check that would be great. I’m new to Asterisk and trying to learn it.
Thank you very much for the help.


#2

I finally figured this out. So, in my case I had no audio in either direction (from caller phone to VOIP phone, and from VOIP phone to caller’s phone). I discovered that the bluetooth adapter I was using was not loading its proprietary firmware (Broadcom). After finding the firmware file it was looking for, in /var/log/messages, I downloaded the firmware and placed in /lib/firmware/brcm/ and voila!, audio in both directions and working. FYI I did try Asterisk 13, and have the one-way audio issue (VOIP phone outbound to caller’s phone, but cannot hear in the opposite direction). Using Asterisk 11 works perfectly.