ChanMobile-Bluetooth Device X has disconnected, reason (104)

Hi, I just installed the latest trunk to try the new chan_mobile. I know i’m near but I can’t find what is going wrong. In the CLI, I’m always getting :

Bluetooth Device X has connected.
– Bluetooth Device X has disconnected, reason (104).

Here is the revelant copy of my mobile.conf:


And the mobile search command :

pbxCLI> mobile search
00:12:D2:CD:7E:E6 X Yes Phone 4

I don’t really know where to start to diagnostic this problem. I’m using Fedora Core 6 and 3-7. My phone is a Samsung SPH-A640

Thx for help

i do currently have the same problem.

openSuSE 10.2
chan_mobile from svn r<408.

Revision 408 is modified to match changle from ast_log to ast_debug.

dmesg is full of
hci_scodata_packet: hci0 SCO packet for unknown connection handle 55

However, when i tried the same with asterisk 1.4.5 some time ago, it worked.

Not sure what changed.

asterisk 1.4.8 is out, so I tried to recompile both asterisk and chan_mobile,
and it works for me now.

But …

first call I made was good, no echo, clear sound. Second call had echo on mobile side. And the third test call was totaly distorted on SIP side.

If anyone has or had same problems, please leave a message

  • echo on mobile
  • one way audio or distorted sound


I have the same problem

bluetooth disconnects after talking for 2 minutes, no call passes 2 minutes

any tips??


When I tryied chan_mobile last time, it just worked. It was on Ubuntu 8.04.2 box, with asterisk 1.6.x compiled from source, Nokia 6234