Cant pickup calls from zap trunk


I’ve been working on this all day with no luck…

The system is elastix 1.1-8 (asterisk 1.4)

This was working, the system has been off for a week or so, and now it doesn’t work.

The sitation is this:
There are 3 PSTN lines, all going in to a TDM400. There is only one inbound route which sends all inbound calls (blank CLID and DID) to a ring group.

When you call on 2 of the 3 lines everything is as it should be. However when you call on the 3rd line, the phones ring, you pick it up, it shows (both on the phone(GXP2000) and in the CLI) that the call has been answered, but all you hear is silence and the calling party continues to hear ringing.

There is another phone plugged in to the lines directly, and you can answer calls from the 3rd line on it.

I’ve tried running genzaptelconf, tried restarting the system, reseating the TDM card, and switching the lines to different sockets on the TDM. Whatever I do, I cant answer calls on that line (regardless of the socket it is in).

I’m completley out of ideas…