Can't get past Loading Screen on Setup Hardware Tab


Hi all

I thought I would have a play with asterisk to see if I could set up a simple tele system at home.

So I got an old PC Amd 1gb 256mB Memory 6GbHD Network Card and a Clone X100p card to connect PSTN line to.

I have installed Asterisk Now just let it do as it wanted not changed any settings at all, I selected the Gui interface.

So I can log on the the box thru internet explorer, and now the fun starts, when I log on it tells me that

Changes detected in your Analog Hardware!!
You have to reconfigure any previously assigned
FXS stations or Analog Service Providers.

Note : Your Analog Hardware will not work properly until you click 'Apply’
Changes button in the Setup Hardware panel.

Well when I click the Setup Hardware tab all I get is Loading Screen…
the panel is blank

I have left it for hours and it’s still the same, so I am unable to click the button.

As a complete newby to Asterisk I have scoured the net and been unable to find a solution.

So I hope someone on here will be ab le to point me in the right direction/


Anyone any ideas at all please,

I have been pulling my hair out with this, I have run the Asterisknow disc on 3 sperate machines and got the same problem on all 3.

I assume that because I have the same problem on all 3 different machines that I have not configured asterisk properly.

Despite searching google for hours I am unable to find a solution.

Help please

Well after a bit more messing about I noticed that there was a Javascript error on internet explorer when I click the Setup Hardware Tab

When I run in debug mode it would appear that the
onload=“localajaxinit()” is the culprit causing the error and the error message is

Error: Expected identifier, string or number

Any ideas how to fix this please it’s driving me nuts

Hi, did you resolve this issue? As I have something very similar.

Or does anyone else know the answer?

Cheers - Lawrence


I have not been able to resolve this problem, I am a complete newby when it comes to Asterisk and Linux.

The way I have currenty resolved the problem is to install FreePbx in a Flash instead of Asterisknow

Ok, sorted it - seems to be an Internet Explorer only issue, so can be safely ignored.

Have u used firefox then? and I take it it worked?

I am seeing this message pop-up, not sure why.