Loaded Asterisk, however something is wrong

I finally got Asterisk loaded on my Linkstation, however after it went through all the steps I get the following message.

“Asterisk not yet configured. Edit /etc/default/asterisk first”

What exactly do I need to do? I am very new to command line so if someone could give me the necessary commands (that I can copy/paste) to complete the install that would be great! Also, I loaded Asterisk using the apt-get install asterisk command, does this version come with a GUI?

Ok I got Asterisk installed, however it seems to be missing some components to fully work. See the attached image for where I am stuck. Any help is gladly appreciated!

Ok I got it to work! However, of course another issue has come up. The GUI program seems to be working (I ran checkconfig and it said all was well), however I am unable to view the GUI interface at the URL indicated. Is there anyway to see what the problem is? Can I run a checkconfig on Asterisk itself? Should I do a fresh re-install of Asterisk? If I do that, will it delete the other associated files that I installed afterwords such as the Asterisk GUI?

Ok I figured out the issue, I needed to tell Asterisk to reload prior to using it. After doing so however, yet another issue pops up. I think that this is what is preventing the software from loading, can anyone tell me if the cdr_sqlite file (missing) is what is causing the problem?