Can't connect to Asterisk with SIP Client

Hey guys,

so I just followed a tutorial to get Call ID Spoofing to run (Caller ID Spoofing: How to do it :) | by vicky | Medium - this one). Before you think something bad: I’m a pentester, trying to get this to work for social engineering attacks.

Now so far I have no idea how everything works together, but tried to do my best to get it working…

So: I’ve got an ubuntu server with a public IP-address… I went to gotrunk and registered a sip endpoint… I downloaded asterisk, installed it and got the config for gotrunk from github… I entered the credentials from GoTrunk in the sip.conf… I downloaded Zoiper, trying to connect, but can’t get it to work though, always getting a timeout.

Now, as I’m new in the topic, I don’t really know what to check… So I am able to connect to the CLI with asterisk -r… I can’t run any command starting with “sip” though, to check the connection to the trunk… Don’t know if that should work…

ps aux | grep asterisk
root 1214 0.0 2.9 598572 27436 ? Ssl 18:19 0:00 asterisk
root 1532 0.0 0.0 6432 720 pts/0 S+ 18:32 0:00 grep --color=auto asterisk

That’s what currently seems to be running…

Can anybody help me on what I need to check to find the problem?

Thanks in advance!

Collecting Debug Information - Asterisk Project - Asterisk Project Wiki

Assuming GoTrunk are in the USA, spoofing may or may not work, but if it does, the CID will be marked as spoofed, and on the ball phone users will learn to not answer such calls.

Soo… I tried completely reinstalling asterisk again… At least I got much further now already… my SIP Client connected succesfully to asterisk and on GoTrunk (which by the way has their HQ at UK), I can also see the connection… However, when trying to starting a call, I get the following debug message:

[Jul 16 19:23:36] ERROR[798][C-00000002]: rtp_engine.c:489 ast_rtp_instance_new: No RTP engine was found. Do you have one loaded?
[Jul 16 19:23:36] NOTICE[798][C-00000002]: chan_sip.c:19665 send_check_user_failure_response: RTP init failure for device <sip:201@myip;transpor                                     t=UDP>;tag=352d0f63 for INVITE, code = -9

Checking in the CLI with module show like rtp returns no result… Trying to start it:

 module load
Unable to load module
Command 'module load' failed.
[Jul 16 19:27:42] ERROR[1224]: loader.c:283 module_load_error: res_pjproject has one or more unknown dependencies.

This is what I get… Any idea why?

I think this the result of trying to force a (deprecated) chan_sip configuration, without also building and loading chan_pjsip.

Hmmm… The sip module seems to be loaded fine though…?

module show like sip
Module                         Description                              Use Count  Status      Support Level                    Session Initiation Protocol (SIP)        0          Running        deprecated
1 modules loaded

chan_pjsip was also configured in the menuconfig (before compilation…)

I believe some of the RTP code is accessed from the PJSIP code.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.