Cannot leave voicemails, Asterisk 1.8 Ubuntu 10.04

I have been attempting to find a resolution to this for about a week now.
My setup involves a Virtualbox install of:
Ubuntu 10.04 LTS x86_64 running kernel 2.6.32-41-server (this only had OpenSSH installed during install)
Asterisk GUI-version : SVN–r5209

Once the base install was completed, I ran

I followed the guide provided at to add and install asterisk-1.8 and asterisk-dahdi.

Once that was completed, I ran

sudo apt-get install subversion
sudo svn checkout /usr/src/asterisk-gui
cd /usr/src/asterisk-gui
sudo ./configure
sudo make
sudo make install
sudo make checkconfig

I edited the /etc/asterisk/http.conf and /etc/asterisk/manager.conf files as well as making a file at /etc/asterisk/manager.d/administrator.conf and then ran this code again.

sudo make checkconfig
sudo /etc/init.d/asterisk restart

The gui will not work at this point. There is a symlink that must be created in order for the Asterisk webserver to serve the files. This code creates the link for you.

sudo rm -Rf /usr/share/asterisk/static-http/
sudo ln -s /var/lib/asterisk/static-http/ /usr/share/asterisk/static-http

I must change ownership of the static-http folder, gui-backups, and scripts to asterisk:asterisk instead of root:root.

sudo chown -R asterisk:asterisk /var/lib/asterisk/scripts/
sudo chown -R asterisk:asterisk /var/lib/asterisk/gui_backups/
sudo chown -R asterisk:asterisk /var/lib/asterisk/static-http/

I then load the asterisk-gui via Mozilla Firefox. http://PBX.SERVER.IP:8088/static/config/index.html

Knowing that I want this server to provide files from tftpd in order to auto provision the phones, I setup my cisco router running dhcp pools to point to my tftp, and then ran the following code to install tftpd.

sudo apt-get install xinetd tftpd tftp
sudo mkdir /tftpboot
sudo chmod -R 777 /tftpboot/
sudo chown -R nobody /tftpboot/
sudo vi /etc/xinetd.d/tftp

In the tftp server file you must place the following code

service tftp
protocol        = udp
port            = 69
socket_type     = dgram
wait            = yes
user            = nobody
server          = /usr/sbin/in.tftpd
server_args     = -s /tftpboot
disable         = no

Restart xinetd, and then put files on the server through tftp for the phones, and then had to change permissions because they can be put on there, but you cannot get them until you change permissions.

sudo /etc/init.d/xinetd restart
sudo chmod -R 777 /tftpboot/

Then reset the phone to factory defaults, and then the phone provisions.

At this point I load my gui and begin changing settings. I changed the range of the extensions, created a dialplan, set the extension for checking voicemail, and finally began creating extensions. I am using Linksys SPA942 phones and just hit the dnd softbutton in order to test a call from one extension to another. I dial my own extension and receive the following results:

-- Executing [252@DLPN_DialPlan1:1] Macro("SIP/252-00000002", "stdexten,252,SIP/252") in new stack
    -- Executing [s@macro-stdexten:1] Set("SIP/252-00000002", "__DYNAMIC_FEATURES=") in new stack
    -- Executing [s@macro-stdexten:2] Set("SIP/252-00000002", "ORIG_ARG1=252") in new stack
    -- Executing [s@macro-stdexten:3] GotoIf("SIP/252-00000002", "0?6:4") in new stack
    -- Goto (macro-stdexten,s,4)
    -- Executing [s@macro-stdexten:4] Dial("SIP/252-00000002", "SIP/252,20,") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/252
    -- Got SIP response 486 "Busy Here" back from PHONE.IP:5060
    -- SIP/252-00000003 is busy
  == Everyone is busy/congested at this time (1:1/0/0)
    -- Executing [s@macro-stdexten:5] Goto("SIP/252-00000002", "s-BUSY,1") in new stack
    -- Goto (macro-stdexten,s-BUSY,1)
    -- Executing [s-BUSY@macro-stdexten:1] VoiceMail("SIP/252-00000002", "252,b") in new stack
    -- <SIP/252-00000002> Playing 'vm-theperson.gsm' (language 'en')
    -- <SIP/252-00000002> Playing 'digits/2.gsm' (language 'en')
    -- <SIP/252-00000002> Playing 'digits/5.gsm' (language 'en')
    -- <SIP/252-00000002> Playing 'digits/2.gsm' (language 'en')
    -- <SIP/252-00000002> Playing 'vm-isonphone.gsm' (language 'en')
    -- Executing [s-BUSY@macro-stdexten:2] Goto("SIP/252-00000002", "default,s,1") in new stack
    -- Goto (default,s,1)
  == Channel 'SIP/252-00000002' jumping out of macro 'stdexten'
[May 15 13:33:10] WARNING[5547]: pbx.c:5119 __ast_pbx_run: Channel 'SIP/252-00000002' sent into invalid extension 's' in context 'default', but no invalid handler

On the phone it says “Call Ended”

The problem is that it tells you that the person and extension XXX is unavailable or on the phone and just hangs up. It does not allow you to leave a message. However, access to VoiceMailMain works without any issues, but you cannot leave a message for anyone from there either. I receive the following results when attempting to leave a message from VoiceMailMain:

[May 15 13:37:57] NOTICE[5607]: app_voicemail.c:7279 forward_message: Mailbox '252' is full with capacity of 0, prompting for another extension.
    -- <SIP/252-0000000a> Playing 'vm-mailboxfull.gsm' (language 'en')
    -- <SIP/252-0000000a> Playing 'vm-extension.gsm' (language 'en')

Any help would be appreciated. I believe I have provided just about ALL the info I can at this point. If you need any more info please request. I am/was attempting to build an Asterisk install with the least amount of manual changes to configuration files, but if I am able to identify the problem, I am willing to add it to the small list of manual edits.


Is asterisk running as the User asterisk ?

if it is , is the directory /var/spool/asterisk writeable by the user asterisk ?

Yes to both questions.
Asterisk is being run as asterisk and asterisk does indeed have access to /var/spool/asterisk with 775 permissions recursively.

As I was walking step-by-step through the configuration of the changes I had made via the asterisk-gui, my friend to whom I was using as a sounding board for my problem pointed out that the “Maximum messages per folder” was unset. This resolved the issue. I created another server identical to this one with the exception that I installed Asterisk-1.8 and Dahdi-linux-complete from source. This did not cause the issue. I believe it was due to the configs packaged with the source vs. from the repo.