Cannot enable chat_motif and res_xmpp in menuselect


I am trying to configure asterisk to work with google voice. After successfully installing asterisk (on centOS 6), we tried to configure it to connect with google voice but we were unable to.

The problem was that I had forgot a step in which I had to go into /usr/src/asterisk*, open up menuselect, and make sure that chat_motif and res_xmpp were enabled. I missed this step and continued with installation. After realizing the mistake, I went back to the menu select to enable them, but I couldn’t. There is an ‘XXX’ over the checkbox disabling me from enabling them. It turns out that for both of these to be checked, I need to have the package iksemel installed.

I got a tar file from online, and i ran make && make install , and it seems to have done so successfully, however, my system doesn’t seem to be picking it up. I still cannot enable the options in the menuselect. When I run $ rpm -qa | grep iksemel , nothing comes up.

Anyone know how I can fix this?

make from a tarball does not result in an RPM being installed, it installs the software outside of the RPM system.

Could you help me out as to what the next step would be?

Read the book at

As there is no evidence that the library hasn’t been installed, I’d restart the Asterisk build at ./configure.