Cannot access Asterisk from outside of local network


#1

OS: Ubuntu 10.04 LTS Server
asterisk-1.6.2.13
asterisk-addons-1.6.2.2
freepbx-2.8.0

Thank you in advance for your advice. I am completely new to networking an ip-telephony, and have been struggling with this issue for many days now, so you are my last hope.

Installed Asterisk and all works fine on one computer, but when trying to access FreePBX dashboard and connect sip softphones from outside I get “server not accessible” error.

Asterisk is installed on Ubuntu which works on a Mac computer through Parallels 7 virtual machine.

Modem/router D-Link2450U. Set port forwarding to local ip 10.211.55.4 (which is displayed in freepbx web interface). Ports forwarded are UDP 5060-5082, 10000-20000, TCP 8088,5038.

Dynamic ip - using no-ip.com, xxxx.serveft.com. DNS port A forwarding. Client works fine, when trying to access xxxx.serveft.com opens D-Link modem admin page. When connecting computer to the internet not through router, the xxxx.serveft.com shows “page not found”

Sophtfone: x-lite

When running command
netstat -an | grep 5060
shows
udp 0 0.0.0.0:5060 0.0.0.0:*

Asterisk SIP settings. Nat yes; IP configuration: dynamic IP; dynamic host: xxxx.serveftpcom, refresh rate 10; local network" 10.211.55.0. Bind port: 5060.

/etc/asterisk/manager.conf

[general]
webenabled = yes
port= 5038
bindaddr 0.0.0.0.
displayconnects=0

[admin]
enabled = yes
secret=xxxxx
secret = YourPass
permit=0.0.0.0/0.0.0.0
read = all,system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
write = all,system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
; deny=0.0.0.0/0.0.0.0

Any ideas what can be the problem here? Thank you!


#2

iptables or other firewall running on the box?


#3

If you don’t know your external host name, you need to use STUN.

I hope you don’t have one of these ISPs that try to discourage servers by changing the IP address whilst the connection is up!


#4

cmendes0101: there is iptables, which I switched off but nothing changed. Not sure how to check if there any other firewalls on the server itself.

Thank you for your ideas on where to look for the issue.

Also, this might help those who reads the post in the future and trying to set up a connection on a machine with parallels desktop. In parallels, you’d need to set a Bridged connection in Network settings so the virtual machine is recognized as a separate computer with own ip in the local network.