CAlls are not comming in


#1

Hello. I have asterisk@home setup behind a linksys befw11s4 router. I use asterisk@home and restored the config to use on my home asterisk server. It works with no problem at work but at home calls can go out but there is a busy signal comming in . I am using FWD, I watched the CLI and did not even see the call his the box? it worked once before it stopped one day and never worked again. Any ideas?


#2

If you watched the CLI and nothing happened, my initial thoughts are the following:

1.) Firewall issues. Make sure you have the ports forwarded correctly. Port 5060 TCP & UDP for SIP, or if you use IAX/IAX2, it should be 4569 or 5036, respectively.

2.) Secondly, do you have a dynamic IP address? If so, it may be changing on you fairly often and not registering with your VoIP provider. You can force a registration several ways, but the easiest is to use the reload command in the CLI.

Hopefully one of these solutions will help you!


#3

cool this appears to have worked. thank you sir!


#4

No problem.

Which one was it? Firewall I’m guessing?


#5

no reload actually! i could not beleive it was that easy!.


#6

What is the configuration tha you have. I can’t make my asterisk box work with incomming calls. I’ve a phone number from voip buster that only works with their SIP client. Do you know what i have to configure to put asterisk receiving incomming calls to?

thanks


#7

I did exactly what is posted above. Did you add those ports to your firewall/router?


#8

I’ve tried with the voipbuster sip client behind the firewall and work’s fine, so i think that can’t be the problem. Can you send-me theconfiguration files for me to see the differences? or if you want i can post my SIP.conf, IAX.conf an extensions.conf .

Nadia Spencer
nadiaspencer@gmail.com