Registration state failed: LinksysSPA921 and Asterisk


I have a problem with getting Asterisk to work with Linksys SPA921 phone.

What I have is:

-1 PSTN line

  • computer with Sangoma A200 card and one FXO module and installed Asterisk
    -4 phones SPA921 connected to PBX via LAN

I have installed Asterisk properly along with Sangoma A200 card with two FXOports (wanpipe drivers installation succesful) following this instruction: with little modifications. I added new user (first only in sip.conf file, then in both sip.conf file and through graphical interface and also only in graphical interface - tried every way) and I edited extensions.conf adding corresponding context. I save configuration restart Asterisk. Then I go to the internet site of phone (I got it static IP - i have Asterisk on and my SPA921 phone on . I fill all necesery things in ext1 : proxy , username, password etc. Phone reboots but it won’t register (under Ext1 you can see : Registration state: Failed) (I followed this instructions during my Asterisk/Sangoma A200/Linksys SPA921 install: … hp/3619986
Could anybody help me with this? What can cause that phone don’t want to register? I’m stuck in a point with Asterisk and Sangoma card installed but not able to connect phone to asterisk . (if i tick on SPA921 internet site to make calls without register it still won’t call - you can hear signal but after dialing number you hear busy sound and call ends automaticly if i tick call without register no you cannot hear anything) please help!!

Firstly, visit and download and patch up the firmware in your handset. I use SPA942 handsets and the firmware on delivery is always old.

What GUI are you using? I have had no trouble in setting up the Linksys handsets with FreePBX.

Can you connect a SIP soft-phone like x-Lite or SJPhone?

Running asterisk with -vvvvv are you seeing any connection attempts from the SPA921? They may give you some insight on the problem.

What OS/distro are you using? Have you opened port 5060 inbound on the firewall? Have you opened 10000-20000 to allow for RTP?

I found out where the problem is. I had it working on DHCP but it wouldn’t work. I switched to static Ip and tried but also wouldn’t work. Then I tried adding user in both sip.conf and through GUI (and of course edit of extensions.conf) but it still wouldn’t work (don’t know why). But today I switched back to dynamic IP and readded user both in sip.conf and GUI and it works. I guess that it was a problem that user was only in GUI or only in sip.conf. But I still don’t know why it wouldn’t work on static IP… Well thank you a lot for so fast response!

Glad you got it working!