Callwaiting cuts me off!


#1

Someone help me before my wife makes me take the system down!!

I’m using a TDM400P connected to my POTS line. I then connect it using asterisk to my grandstream ATA.

Anyhow, when my wife is on the phone and someone else calls, my wife tries to keep talking but the other person can’t hear her anymore. Frustrated, my wife presses flash and is inded able to talk to the new caller but when she presses flash again, her first call is lost.

Does anyone have a working config that is compatible with external call waiting? I’ve tried changing callwaiting=yes or no in my zapata.conf but there was no change.

sip.conf:

[quote][carrie]
type=friend
secret=password
qualify=yes
nat=no
host=dynamic
canreinvite=yes
mailbox=101@default
context=internal
[/quote]

zapata.conf:

[quote][trunkgroups]
; define any trunk groups
[channels]
; hardware channels
; default
musiconhold=default
usecallerid=yes
hidecallerid=no
callwaiting=no
threewaycalling=yes
transfer=yes
rxgain=3
txgain=0
echocancel=yes
echotraining=yes
echocancelwhenbridged=yes
; define channels
context=incoming ; Incoming calls go to [incoming] in extensions.conf
signalling=fxs_ks ; Use FXS signalling for an FXO channel
group=1
channel => 1 ; PSTN attached to port 2
[/quote]


#2

I think there was a bug in some of the firmware on them.

from the wiki

Call waiting
Reportedly working for firmware 3.81 and later: Pressing FLASH once puts the 1st call on hold and answers the 2nd call. Pressing FLASH again puts second caller on hold and returns to first caller, etc. For this to work you must check your “send flash as DTMF event” option in the phone’s setup: for call waiting you must have this option set to No (false).

For old firmware versions only where call waiting cannot be turned off in the phone’s Web interface: Use incominglimlit=1 in sip.conf if you want to switch off call waiting and to prevent the phone ringing loudly in the middle of your conversation when a 2nd call comes in (“call waiting signal”). This setting requires a username= statement.


#3

I appreciate the response but I’ve read that too and I wasn’t able to get anywhere with it - I’ve set the grandstream the way it tells me to but I still have that issue.


#4

Hi

First thing I would do is change canreinvite to no and see if that makes any difference.

Personaly had a Cisco ATA186 that used to cut calls of when call waiting happened on occasions

Ian


#5

That would mean that I can’t transfer from one extension to another right?


#6

Yay! It works!

OK, here’s what I did:

zapata.conf
callwaiting=no

sip.conf
canreinvite=yes

In my grandstream ht286 setup
Enable Call Features: No
Disable Call Waiting: Yes

Why does this all work? I’m not sure but I can now switch back and forth between calls on my regular cordless phone with no issues.