Call waiting disable in Asterisk 1.4

Hi folks!
I´m trying to disable call waiting signal from interrupting the next call.
I´ve set callwaiting=no in sip.conf,
tested it but doesn´t work.

Any help will be thanked!!!

I’m assuming you are trying to stop call waiting on lines coming in from the telco. In this case, you should try setting “callwaiting=no” in /etc/asterisk/chan_dahdi.conf. If you are running an older version of Asterisk 1.4 that uses Zaptel, the file to edit would be /etc/asterisk/zapata.conf.

Actually I´m trying to disable call waiting in calls both from internal extensions as from the telco.
I ´ve already set callwaiting=no in zapata.conf (context “channels”) but doesn´t work.

Thanks!