Call barging help


#1

I tried using chanspy to barge calls. but the audio quality sucks so bad that you’ll swear you are on a very lagged online game audio.

I tried this

[barge]
exten => *898,1,Answer
exten => *898,2,Wait(1)
exten => *898,3,Goto(spy,s,1)
exten => *898,4,Hangup

[spy]
exten => s,1,BackGround(please-enter-the)
exten => s,n,BackGround(extension)
exten => s,n,Set(TIMEOUT(digit)=5) ; Set Digit Timeout to 5 seconds
exten => s,n,Set(TIMEOUT(response)=10) ; Set Response Timeout to 10 seconds
exten => s,n,WaitExten(10)
exten => _XXX,1,ChanSpy(SIP/${EXTEN}|q)

exten => i,1,PlayBack(bad)
exten => i,2,PlayBack(extension)
exten => i,3,Goto(s,1)

[default]
include => barge

really. when you dial *898 you get the greeting please enter the extension. and of course you will enter the extension of the phone you want to barge and it will connect but the audio really sucks. can anyone help me more about call barging?


#2

That is a bit odd, I’ve never had any problems like that with chanspy.
What versions of asterisk are you running?

If all else fails you can do barge the way FOP does it. Use the manager to redirect the call to a meetme conference where you can listen in.


#3

if your audio quality sucks, that is probably a zaptel issue…are you running any digium hardware? using ztdummy if there is no digium hardware?

that would be my first guess…past that, it would be IRQ sharing, etc…standard tuning.


#4

I am using 1.2.4

We dont have any telco hardware on it. its just a box which is connected to the lan.

any docs on ztdummy?

and FOP?

sorry for being totally clueless, I just followed some instrucstion I saw on the internet.


#5

I tried this

[root@nicole asterisk]# uname -r
2.6.9-22.EL
[root@nicole asterisk]# modprobe ztdummy
Notice: Configuration file is /etc/zaptel.conf
line 0: Unable to open master device ‘/dev/zap/ctl’

1 error(s) detected

FATAL: Error running install command for ztdummy
[root@nicole asterisk]#

any tips? I really want to make this call barging happen.


#6

have you downloaded, compiled, and installed zaptel? if you have, i THINK you should be able to modprobe ztdummy without issue…

check here for more info: voip-info.org/wiki-Asterisk+timer+ztdummy

that SHOULD fix your audio issues.


#7

I am having same problem with chanspy. voice quality sucks.
Protocol bieng used is SIP