Basic outside call with FWD


#1

Hello,

I’m going crazy ! :smile:

I read and configure several times my *@home without sucess.

Basically I have :

Routeur1 : staticIP and domain name (LAN1)

  • Asterisk@home
  • some softphone

Routeur2 : staticIP and domain name (LAN2)

  • some softphone

To call a softphone from an other softphone inside the LAN1, no pb, I just call the extention and everythong works.

But I can’t call from LAN2 to LAN1 (or LAN1 to LAN2). LAN2 softphones registered well, but I have timeout error.

I tried also to add iax (from FWD). I tried several configs as on this forums people use iax2.fwdnet or pulver. When I try to call a FWD number (for exemple : 393612 or 19197543700) I have no connexion.

Have you tried to do the same ?
How are your configuration files ? DO you have a simple working example for to LAN with NAT routers and FWD ? I also tried voip-info.org but configurations didn’t worked.

My purpose is :

I want to call anybody from LAN1 to LAN1, or LAN2 to LAN2 or LAN1 to LAN2, and I also want to call Voip SIP number. I also want to receive theses calls… !! What number should a FWD user tap to call me ?

I’m not interested for calling RTC numbers for the moment.

Any help would be really welcome !!
I didn’t find any books in France about Asterisk

Sincerly,
remi


#2

OK. I solved it. It was a problem of the LAN2 router. I changed firmware and it’s now OK.

The only things is that when I call SIP number (like a FWD number) I have the voice message : all the circuits are busy, please try again later…

Any idea ?


#3

Hi,

that just sounds like a router problem to me. The router on LAN 1 needs to be forwarding the ports that the phones on LAN 2 are using to the IP of the asterisk box.

PLEASE NOTE I am assuming asterisk is on LAN1

Also, the router for LAN 2 needs to forward the ports used for the phones connected to LAN2 to EACH PHONES IP.

Assuming you have done this, make SURE you have opened ALL such ports (I.E. ALL ports used by the phones on LAN 2) BI-DIRECTIONAL on both routers.

That should help you.

Just out of curiosity, are you running two lans because you have two locations?

d:o)


#4

Hello,

thank you for your help. It was the second router (on the lan where asterisk is NOT) which had troubles : uPnP was not working.

Just out of curiosity, are you running two lans because you have two >locations?

Yep exactly that’s my configuration. Are there any other solutions ?

remi