Asterisk voicemail change language problem

Hi, support

Really glad if you support on this.

I am asterisk users, and I want to change the voicemail language to Cantonese.

Meanwhile, I make all the Cantonese sounds files and rename them according to English sound files name.

Finally, I replaced the English file with Cantonese sound files record by myself.

The problem is that the language structure or gamma is totally different between two languages. Although, the mailbox is saying Cantonese, but it can’t be used. The sound file is played in wrong order. It seems other places like the program also need to be changed accordingly. how to settle this?

Desire for your help and indication.


Assuming that voicemail is localisable at all, you should not replace the English sound files; you should add a sounds/zh directory (I’m not sure if Asterisk can cope with zh-HK).

If it is localisable, for things like numbers, you will need say.conf entries.

A quick look at the code suggests that it is localisable, does know about Taiwanese syntax (which may be close enough), and that you might need to set the language and locale options (I didn’t investigate how locale was used).


i made the directory to /zh

and now the syntax is Taiwanese.

the problem is that numbers/times not correct.

i had a look at the say.conf, don’t understand how to configure it . :cry: :cry:

Looking at it seems that a patch was accepted that hard codes support for Chinese number syntax under the bogus language code twz (there is no such ISO language code - ISO lumps all of Chinese under zh and the internet uses country modifiers, so there is no actual way of saying Hokkien, which would be closest to the correct name for Taiwanese - I think the actual Taiwanese support was written with Mandarin in mind).

My feeling is that this is a bug, but in the short term you probably need to change twz to zh in the source and recompile. I have not verified that voicemail will actually use this.