Asterisk & Sphinx2 - /dev/dsp error


#1

I am running a server on a hosted platform with FC4 and while I do have alsa installed for various programs I do not have a /dev/dsp. I have compiled and installed Sphinx2 to work with Asterisk.

The issue is, that whenever I try to load Sphinx2 I get this error:

I have tried things like /dev/MAEKDEV dsp - chmod 666, but still get the error. Any ideas on how to make this work? Either through disabling the need in Sphinx2 or creating the device?


#2

I if my memory serves, you can have OSS and ALSA on the same machine. You might have to set them up as modules in the kernel though.

ALSA (Advanced Linux Sound Architecture) is the current sound system for Linux, where OSS (Open Sound System) is depreciated but seems still used for many applications.

Recompile your kernel with both ALSA and OSS.


#3

Yes, I thought about that. But after some fiddling, I believe I have it working without /dev/dsp, as I do not need a microphone as I am only using this with Asterisk. I will post the final work around once I have finalized the testing.


#4

That would be great… I would love to play with voice recognition

Good luck