Asterisk over multiple networks

Ok so I have asterisk running on a server and it works fine. When I have computers connected directly to the server, I am able to log into the softphones on the network. But when I have these computers connected to the server through a different wireless network (routing is turned on, pinging occurs back and forth), the softphones can’t connect to asterisk(408- Request Timeout).

I’m not sure if I’m explaining this correctly.

I have a wireless network that can get to the network the server is on. When I’m connected to the network the server is on, all works well. When on the wireless network, everyone still sees each other, but the softphones will not connect.

Is there something in asterisk to allow for multiple networks?

Here is the [general] from my sip.conf:

[general]
context=default
allowoverlap=no
bindaddr=asterisk server IP
bindport=5060
disallow=all
allow=ulaw
allow=gsm
language=en
canreinvite=yes

Thanks!

bindaddr=asterisk server IP [quote]

Try to change this parameter to 0.0.0.0

bindaddr = IP_Address : IP Address to bind to (listen on). Default 0.0.0.0 (all network interfaces).

Thanks,
Suresh[/quote]

Yea I’ve read up on all that. Because of the routing though, the server’s IP is 10.10.9.x, but its IP address over the wireless networks is 10.10.10.x.

When bindaddr=10.10.9.x, and the clients connect from LAN, it works fine, but the wireless computers can not.

I already tried changing to 0.0.0.0 and it didn’t help…

Hope this clears up some, still having trouble.

Thanks

try in sip.conf
[general]
localnet=10.10.9.0/255.255.255.0
localnet=10.10.10.0/255.255.255.0

regards

That didn’t seem to work, should I be using it in conjunction with binaddr?

Thanks for the response though, I’m sure something will work eventually…

well i’ve read up on a few things, and changed some, but now i’m getting a 401 unauthorized message from asterisk

To put everything in one place, here is the setup

A wireless network, 7.1.1*, an asterisk server running on 10.10.9.5, which is behind a NAT with a nat’d IP of 10.10.10.5

None of this is connected to the internet, all internal.

I have X-lite on a laptop connected to 7.1.1.* wirelessly.

So I’ve got it narrowed down to the password. I realize these aren’t required but I’de like to use them for each user.

So the fix was to remove a users password and I can connect, but with the password, I receive a 401 unauthorized. NAT seems to be working great, and the only hold up is this password issue.

Any ideas?

Here is some debug output.

 
<--- SIP read from 7.1.1.29:34928 --->
REGISTER sip:10.10.9.5 SIP/2.0
Via: SIP/2.0/UDP 7.1.1.29:34928;branch=z9hG4bK-d87543-ae88ed794a170456-1--d87543-;rport
Max-Forwards: 70
Contact: <sip:chase@7.1.1.29:34928;rinstance=32e0513d1bfcc538>
To: "CP"<sip:chase@10.10.9.5>
From: "CP"<sip:chase@10.10.9.5>;tag=f165cc3d
Call-ID: ZDhlN2YyNDg1YWQ5NzRjZmU5ZGQ5M2UxOTI2NTJlNTc.
CSeq: 1 REGISTER
Expires: 3600
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO
User-Agent: X-Lite release 1011b stamp 39984
Content-Length: 0


<------------->
--- (12 headers 0 lines) ---
Using latest REGISTER request as basis request
Sending to 7.1.1.29 : 34928 (NAT)

<--- Transmitting (NAT) to 7.1.1.29:34928 --->
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 7.1.1.29:34928;branch=z9hG4bK-d87543-ae88ed794a170456-1--d87543-;rport;received=7.1.1.29
From: "CP"<sip:chase@10.10.9.5>;tag=f165cc3d
To: "CP"<sip:chase@10.10.9.5>
Call-ID: ZDhlN2YyNDg1YWQ5NzRjZmU5ZGQ5M2UxOTI2NTJlNTc.
CSeq: 1 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Contact: <sip:chase@10.10.9.5>
Content-Length: 0

Thanks

I think this is a domain thing. Play around with the xlite settings by putting in the 10.x address as the realm

regards