Softphone won't connect to Asterisk from Outside (Wan)

Hi Guys,

I got my Asterisk setup and it seems to be working well.

I don’t have any hardware yet so I’m using 2 X SJphone (Softphone). From inside my Network, I can call Voice Mail, Meetme, IVR and each other.

When I use the same settings from a remote location, I can’t seem to connect to Asterisk. I see nothing in the Logs on Asterisk.

I setup my Router to forward:

UDP 5060 - 5065 192.168. 2.200
UDP 10000 - 20000 192.168. 2.200
TCP 5060 - 5065 192.168. 2.200
TCP 10000 - 20000 192.168. 2.200

(Since UDP didn’t work by itself, I also tried adding TCP)

This setup didn’t work so I tried setting the DMZ (Point All ports) to my Linux Box. That didn’t work either.

What should I try next ?



google sip_nat.conf

make sure your IP at the router is a public and not a non-routed one

setup a stun server in the softphone set the log so it shows and then see what the deal is

on the server you would do a sip debug or just watch the port

ngrep -d any -Wbyline -t port 5060

Have you configured your sip.conf to be “nat aware”? You probably need something like:


Thank you very much for the replies guys.

I added the following file:



This is the weird part, I was sure that I added #include sip_nat.conf in my sip.conf file (last night) but now the include is missing.

Now, (from inside) I can actually dial and I get an answer. I’ll try today from the Outside and let you know.

Thanks again,


Hello Again,

I had the following settings in my sip.conf file (not sip_nat.conf)


Now my “remote” or “offlan” softfone car register and make calls to all my extensions. (I still have all my router forwards as stated in my previous post.

But when I added: externip=, the DTMF’s stopped working on my “Local”. When I call the meetme conference application, it just ignores all my DTMF’s.

I tried to change the DTMF options in SIP.CONF :

dtmfmode=rfc2833 or dtmfmode=inband and I get the same results, ignored DTMF’s.

Any ideas?