Asterisk dialling prematurely

When I pick up the handset of the phone (a Polycom SoundPoint) and start inputting a phone number Asterisk already starts dialling after a few digits have been entered.
This doesn’t happen when you dial the number handsfree (with the phone still on the hook)

Our internal phones have extensions ranging from 11 to 19.

My dialling plan looks like this:

exten => 11,1,dial(sip/11||wW)
exten => 13,1,dial(sip/13||wW)
exten => 14,1,dial(sip/14||wW)
exten => 15,1,dial(sip/15||wW)
exten => 17,1,dial(sip/17||wW)
exten => 18,1,dial(sip/18||wW)
exten => 19,1,dial(sip/19||wW)

exten => _[0-9]X.,1,dial(mISDN/g:mylines/${EXTEN}||wW)

Internal calls are two digit numbers and all other calls (numbers consisting of 3 or more digits) should be dialled on our outside lines.

Why does Asterisk start dialling prematurely?


A phone cannot start dialing if it is onhook. If a phone is dialing early I would look at the phones configuration. I would also put a softphone on the system and see if the same thing starts to happen with it.

That’s why the problem doesn’t occur when you input the number when the phones on the hook and then press send.
However when you dial normally (with the handset in off the hook) Asterisk dials before the full number has been entered.


I would check the settings on the phone and see if there is something different, and also I would still try to put a softphone on and see if it does it as well

I seem to remember that there is an option, something like “overlap dialling”, which is normally disabled, but allows one to complete the phone number after the initial SIP INVITE.

You need to configure the phone’s dial plan. There are entries that tell the phone to begin dialing after 7 digits, 10 digits (or 11 if the first digit is a 1), etc. I haven’t done this for a Polycom in a long time but have done so extensively for the Cisco phones. You can probably find what you need at Polycom’s website.

Thank you all for responding!

I agree that it is probably a setting in the phones.
In the webinterface I see:
Digitmap Timeout:
Remove End-Of-Dial Marker:
Digitmap Impossible Match:

I guess the Digitmap is the one to change but I’ll have to find out how to do that.
I would like to set the phone so it doesn’t dial at all until the timeout. Similar to how non VOIP phones work.