Asterisk and softphone ( X-Lite )


I was asked to set-up a dial plan in such a way that I’ll be able to make a call to colleagues extension from the softphone on my laptop to his extension.

To do the above will I need only asterisk up and running or also Zaptel and libpri?

Hope I need to edit my sip.conf and extensions.conf files to make it work ( If I’m not wrong )

I’m going to work with Ubuntu-9.04 Desktop version.

Help me please!

EDITED: this is wrong. See next post for correction.


As long as both are SIP phones you would not need libpri or Zaptel.

Zaptel is used for analog telephones and connecting to the PSTN (or analog PBX). Libpri is used with Zaptel if you have a T1 PRI interface to your Asterisk box.



I’m so sorry but I forgot something; you really need a timing source for Asterisk. There are two ways to get one; hardware timing source or software timing via “ztdummy”. If you do not have a Digium (or other manufacturer) card in your system you’ll need Zaptel for software timing. Make sure you have kernel-devel installed on your system so it will compile:

yum install kernel-devel

I don’t know if this is required on all Linux distros but I have run into it enough that whenever I am going to compile zaptel I make sure I have it before I try.

Sorry for the confusion,


I get below error when I get into the zaptel folder and run make command.

/usr/src/asterisk/zaptel-$ sudo make
make[1]: Entering directory /usr/src/asterisk/zaptel-' make -C /lib/modules/2.6.28-15-server/build ARCH=i386 SUBDIRS=/usr/src/asterisk/zaptel- HOTPLUG_FIRMWARE=yes KBUILD_OBJ_M="pciradio.o tor2.o torisa.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o wcusb.o zaptel.o ztd-eth.o ztd-loc.o ztdummy.o ztdynamic.o zttranscode.o wct4xxp/ wctc4xxp/ xpp/ wctdm24xxp/ wcte12xp/" modules make[2]: Entering directory/usr/src/linux-headers-2.6.28-15-server’
CC [M] /usr/src/asterisk/zaptel-
/usr/src/asterisk/zaptel- In function ‘ztdummy_hr_int’:
/usr/src/asterisk/zaptel- error: ‘struct hrtimer’ has no member named ‘expires’
make[3]: *** [/usr/src/asterisk/zaptel-] Error 1
make[2]: *** [module/usr/src/asterisk/zaptel-] Error 2
make[2]: Leaving directory /usr/src/linux-headers-2.6.28-15-server' make[1]: *** [modules] Error 2 make[1]: Leaving directory/usr/src/asterisk/zaptel-’
make: *** [all] Error 2

How do I fix this too? :frowning:

I’m going to go out on a limb and suggest that it might be your OS. You are using a Ubuntu Desktop distro, not a server distro. Right now I’m using Fedora Core 9 as my known good Asterisk OS. Even then I have to install a couple of packages to get a good compile on zaptel and asterisk-addons:

yum install kernel-devel //for zaptel compile

yum install mysql-devel //assumes you already have mysql installed; this gets you your mysql cdr addon to compile

I’m using Ubuntu-9.04 server distro.

But when I do as below:
$ sudo /etc/init.d/asterisk start

  • Starting Asterisk PBX: asterisk [ OK ]
    orea@oreapbx:~$ sudo /etc/init.d/asterisk stop
  • Stopping Asterisk PBX: asterisk [ OK ]

but the command sudo asterisk -r
says unable to connect to remote.

How do I fix this? Do I need to do the whole process all over again ?

BTW, why I don’t see the asterisk CLI?

OK, try this:

#su -

then give it the root PW. This actually makes you root. I avoid Ubuntu as it is an SOB to get it to allow you to login as root.

#lsmod | grep zap

if you see a bunch of zaptel stuff this will tell you if zaptel is running; it needs to be running at least so you have a software timing source with ztdummy. If zaptel is not running enter:

#service zaptel start

then try:

#service asterisk start

post what you get.

“#” is a substiture for your linux prompt.

zaptel has been replaced by dahdi. I think it quite unlikely that zaptel will support that version of the kernel. dahdi may, provided you use a current version, and the kernel is out of beta.

Centos was on about 2.6.16 when zaptel became dahdi.

So you say I need to replace Zaptel with Dhadi?

How I do that?


The commands I gave doesn’t seem to respond it’s just blank.

Help me!

First I’ll brief what I’m trying to do. I need to set up asterisk PBX on a Desktop with static IP address ( my machine’s address ), then once it’ll all working fine, I’ll install a softphone on my windows laptop and try to call my colleagues extension through the softphone with static IP address as domain and proxy in my softphone.

With proper Dial plan in my etc/asterisk/sip.conf and etc/asterisk/extensions.conf, I’ll be able to make call from my softphone.

I’m using Ubuntu-9.04 server version for this purpose. But my zaptel is giving me problem. I tried to setup asterisk-gui for remote access and I followed the below steps:

sudo nano etc/asterisk/http.conf ( Uncommented the lines )

enabled = yes
enablestatic = yes
bindaddr = My static Ip address ( Ubuntu-9.04 machine address )
bindport = 8088
prefix = gui

sudo nano etc/asterisk/manager.conf
enabled= yes
webenabled = yes
port = 5038
bindaddr = ( This is where I’m pretty doubtful )

secret = admin_pwd
read = system,call,log,verbose,command,agent,user,config
write = system,call,log,verbose,command,agent,user,config

sudo nano etc/default/asterisk


$ sudo make checkconfig

It displays everything seems to be good, afetr few checks it displayed Good Luck—

But when I typed brat:8088/gui/static/config/index.html

It displayed failed to connect PAGE.

Am I doing it in right way, if YES what I’m I missing or wrong in the above procedure.

Also as requested in my previous reply, how I NEED to replace zaptel with DAHDI if that was my problem for the earlier issue.

Any help would be just great!