Asterisk 11 /call-limit/callcounter

Hello.
I have switched from Asterisk 1.4 to 11.6.0
Everything work great, but as many I have problem with call limiting.

So…I started to use ‘queues’. It works perfect, of course I use options:

;sip.conf
callcounter=yes ;at every sip client/phone at company

;queues.conf
ringinuse = no

So…when sombedoy call the company, and the dialplan moves the connection to the queue, the cmd ‘sip show inuse’ shows that a member answeared the call, and the next one will not be forwarded to that member - and OK - it works.

But, If I called the same extension from the ‘inside’ od the company, simply:

Dial(SIP/${EXTEN}

and the called station is ‘in use’ because of the queue…I do not receive ‘busy’ signal.
How can I resolve that problem?
I have read a lot of docs, but with no success ;-(.

Best regards.

The easiest way is to disable call waiting on the phone itself. Call limits were always a bit funny and I’m not sure that the replacement, group counts, is compatible with the use of queues. You could, probably, use a local channel to allow you to use group counts.

I was trying to use group counts with queues too. No success ;-(.
Any other ideas without modyfing the phones on desks?

Use the GotoIF with Device_State to provide the congestión tone.

This is it,

exten => _2XX,1,Verbose(1,***The device state is: ${DEVICE_STATE(SIP/${EXTEN})})
exten => _2XX,n,ExecIf($["${DEVICE_STATE(SIP/${EXTEN})}" != “NOT_INUSE”]?Busy)

Thank you.!