Asterisk 1.8 not even trying to sync caldav


I’m trying to get asterisk synched with caldav (google calendar), the problem is that it doesn’t get the events from the calendar; when I run “calendar show calendars” in the console, it always shows status “free”, even if it should be marked as busy and when I run “calendar show calendar xxx” it doesn’t show any events. (I created events that last weeks, marked them as busy and are public)

Also, I started asterisk with level 5 debugging and verbosity, but there are no messages related to or (I also ran core set debug/verbose 5 for both modules just in case).

It seems that asterisk is not even trying to get the events from the calendar, when I try the url in firefox, it asks me for user and password, I use the ones in calendar.conf and I get the events. Modules and are loaded of course.

Here I provide my calendar.conf code:

;there is no newline in the above line

I also tried:
putting spaces arround ‘=’ symbol, using ical instead of caldav, different values for refresh, etc etc.

Any help/suggestion will be more than appreciated.
thanks a lot.


Nevermind, I tried the solution in posted in viewtopic.php?f=1&t=85623 and it worked.

Maybe something changed in google’s end, because a month ago synching caldav worked fine with google.

Bye and thanks.