Asterisk 18 Calendar stopped working

I use the calendar function in my setup and this worked for more than over 2 years. Suddenly it stopped working without a known reason.

user =
secret = trytofindit

Because my setup/version was EOL i’ve upgraded a copy to asterisk 18, but still no improvement and for me very difficult to debug… The calendar is accessible in eg thunderbird, so no technical issue with another app and loging in in the calendar. But how do I check the detailed handshake between Asterisk and this caldav calendar ?

I don’t think there is any mechanism in the res_calendar modules to do this. You might want to use tcpdump or take a packet capture to inspect the traffic. It’s not really much of a handshake, though. Without knowing why the server is rejecting the requests, it’s just speculation.

Last year there was an issue with Microsoft calendars suddenly not working (that was resolved), but this sounds different and unrelated.

Current workaround is to use an Ical calendar named the same as the caldav calendar that is still causing issue. Can someone confirm that his/her caldav calendar is still ok and is there a public caldav calendar available for testing so I can determine what is the cause in my setup: Asterisk or Sogo (Sogo calendar works 100% with thunderbird at the moment)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.