Help connecting w/ &

hey folks,

i was was able to see my upcoming events recently and now i cannot see them.

i get this message in my log:

i get the message every refresh=n of minutes. here is my calendar.conf

[mygooglecal] type=caldav url= user=myacct secret=mypass refresh=1 timeframe=10080 channel=Local/201@mycontext context=google_cal extension=start Autoreminder=2

i removed all the modules from /usr/lib/asterisk/module
ran make distclean, ./configure, make && make install

Ive tried changing settings to my calendar.conf file

Ive tried recreating my calendar.conf file

Ive tried matching my [mygooglecalendar] with the actual name of my calendar

Ive tried publicly sharing my calendar

Ive tried to allow Google calendar API

Ive tried reinstalling neon && neon-devel

i tried upgrading neon to 0.29 i don’t think i was sucessfull installing it, however it shouldn’t be required. i now have 0.25 using centos 5.8

Ive been looking all over google with not enough information provided.

I’m on day 5 trying to solve this issue with no success.

could anyone possibly give me a lead or a pointer on how to diagnose this problem?

your help is appreciated

thanks in advance

edit: forgot to mention

when running “calendar show calendars” i get this output

[code]sip*CLI> calendar show calendars
Calendar Type Status

mygooglecalendar caldav free

and when running “calendar show calendar mygooglecalendar” i get this output

sip*CLI> calendar show calendar mygooglecalendar
Name              : mygooglecalendar
Notify channel    : Local/201@mycontext
Notify context    : google_cal
Notify extension  : start
Notify applicatio :
Notify appdata    :
Refresh time      : 1
Timeframe         : 10080
Autoreminder      : 2

…and yes, i have upcomming events i created and ive also tried the time refresh to 15 and the timeframe to 60

none of the above methods have worked for me

I’ve ran into the same issue connecting to Google Calendar. Your calendar.conf and calendar show… output is consistent with my environment.

The last time my Asterisk server successfully processed calendar activities was on January 23, 2013. I’ve been using a Google Calendar integration for a couple of years to fire off several scheduled events per day. According to the Asterisk CDR it stopped working on January 23, 2013. Since my Asterisk server hasn’t been updated (OS or Asterisk build) in months, it’s not a configuration issue on my Asterisk server.

There is a Google blog post from December 14, 2012 indicating that they are discontinuing several features of Google Calendars, but nothing specific on CalDAV.

I popped into Safari and events.ics was downloaded and opened by the Calendar app on my Mac without an issue and all of the calendar events were imported just as they exist on the Google Calendar.

I realize this doesn’t do much to help either of our situations, but it does at least confirm that you are not the only person burdened by this issue.


thanks for the confirmation! Ive spent days trying to figure it out. no one on irc (#asterisk) was able to confirm that they were experiencing the same issue.

well now that this is clear, hopefully someone else can provide us with a solution.

right now im wondering two things…

im wondering if i build my own caldev server, will i be able to connect && if there would be any point in upgrading my asterisk version to either 10 or 11 for solving this issue?

EDIT: maybe your diagnosis is wrong! i just tried connecting with apple… direct link and credentials, and i just tried a free online service called which allows calendar ical sharing. both give me the same error as the google cal.

I had the same problem, a week ago my calendar phone reminders stopped working beceause no events were collected anymore.
I tried chancing from caldav to ical. Still no events. Then I rebuild my server in vmware and by a typo I discovered a “solution”: change the calendar type to ical but keep the url pointing to caldav:

type = ical
url = 
user =
secret =password
refresh = 10 
timeframe = 120 
channel = local/1535@from-internal-calendar
context = from-internal 
extension = 225
waittime = 60

This gives:

api*CLI> calendar show calendar GoogleCalendar
Name              : GoogleCalendar
Notify channel    :  local/1535@from-internal-calendar
Notify context    : from-internal
Notify extension  : 225
Notify applicatio :
Notify appdata    :
Refresh time      : 10
Timeframe         : 120
Autoreminder      : 0
Summary     : Gebeurtenis zonder titels
Description :
Organizer   :
Location    :
Categories  :
Priority    : 0
UID         :
Start       : 2013-02-21 10:18:00 PM +0000
End         : 2013-02-21 11:18:00 PM +0000
Alarm       : 2013-02-21 11:17:00 PM +0000


Hello all.
I am having a similar problem. I have Asterisk 11.19.0 and I am trying to get it to use a Synology NAS Caldav server. My iPad can put appointments onto the server and I can see the files as they are added. I have a firewall between the two servers and I can see traffic starting every 5 minutes but, regardless of appointments, my time is always shown as free and no events show up.

I have tried the changes to the module code but it had no effect. Any other suggestions?

Some relevant info below:

Asterisk 11.19.0, Copyright (C) 1999 - 2013 Digium, Inc. and others.
Created by Mark Spencer <>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
Connected to Asterisk 11.19.0 currently running on AsteriskBox (pid = 1715)
AsteriskBox*CLI> calendar show calendars
Calendar             Type       Status
--------             ----       ------
Cal_Chris            caldav     free  
AsteriskBox*CLI> calendar show calendar Cal_Chris
Name              : Cal_Chris           
Notify channel    : SIP/Downstairs      
Notify context    :                     
Notify extension  :                     
Notify applicatio : playback            
Notify appdata    : Chris-Check-Cal     
Refresh time      : 5
Timeframe         : 600
Autoreminder      : 0
AsteriskBox*CLI> exit
Asterisk cleanly ending (0).
Executing last minute cleanups
chris@AsteriskBox:~$ cat /etc/asterisk/calendar.conf

Thanks for all the help so far…

I am still trying to sort this one out. If I do a tcpdump of all traffic going to/from my CalDAV server I can see that there is a response coming in to the Asterisk server.
REPORT /homes/chris/Chris HTTP/1.1
Connection: TE
TE: trailers
Host: X.Y.Z.8:5005
Content-Length: 484
Content-type: text/xml
Authorization: Basic Y2hyaXM6SWxvdmVCZWs=

<?xml version="1.0" encoding="utf-8" ?>

<C:calendar-query xmlns:D=“DAV:” xmlns:C=“urn:ietf:params:xml:ns:caldav”>
<C:expand start=“20151016T031236Z” end=“20151016T131236Z”/>
<C:comp-filter name=“VCALENDAR”>
<C:comp-filter name=“VEVENT”>
<C:time-range start=“20151016T031236Z” end=“20151016T131236Z”/>


Is this what Asterisk is looking for or should there be more/less in the response?

This is starting to drive me crazy. Please help.

Just thought I’d try to get a response to my fourth post.

Till now it’s been no responses for three posts.

In the immortal words of Pink Floyd… Is there anybody out there

There are, but calendaring is not something that is used by a lot of people.

Iiiiiiiiiiiii have become, comfortably numb.

Can anyone confirm that is does work. If not I suppose I’ll get a bit more numb.
:smiley: :smiley: :smiley: