Aggressive suppression


#1

Hi guys, asterisk is very new for me.
I use voipjet for calls into the pstn. so my problem is, that in moments of silence the call seems to be dead. and thats not so good.
i use the ilbc-codec. in my phone the “silence suppression” is not active. when is use other sip-providers there is a steady stream, perhaps CNG.
only when i use asterisk/voipjet there are these silent moments.
i searched for hours at www.google.com, but fopund nothing. So you are my last hope.
Marpi


#2

Asterisk doesn’t have anything to do with that. All asterisk does is pass packets from one end of the connection to the other end. If your phone hasn’t got comfort noise generation, there’s not much you can do - apart from get a new phone. You could check if it’s possible to change the phone’s setting so it doesn’t cut out the lower amplitude sounds.


#3

Acoording to the manual the phone is able to provide CNG:

“Support Silence Suppression, VAD (Voice Activity Detection), CNG (Comfort Noise Generation), Line Echo Cancellation (G.168) and AGC (Automatic Gain Control)”

It’s the Grandstream GXP-2000.


#4

MArpi,

The thing I am having a problem with is that there is silence when the echo cancellor mutes incoming echo. It is not the phone because I have used a few including the GXP2000. The silence I am speaking of is when the echo canceller does it’s job and mutes the incoming echo. I believe it is a problem with the echo cancellor. It needs some mechanism added where the echo mute is replaced by comfort noise.

I think what you are talking about is something that the phone itself should generate.


#5

Hi,

I am having the same problem. In my case it also goes totally silent. Also, in case I am speaking when the other person is speaking, the other person goes silent for a couple of seconds.

Note, this ONLY happens with voipjet. If I use FWD there is not such thing going on. I have tried all sorts of different settings on the phone, but nothing helps.

// Jonas


#6

Have you guys tried the two updates as part of the Digum developer code. One modifies the mec2 canceller header files which I have found noticeably improves regular echo cancellation. I would try that first. The other modifies how aggressive cancellation works. I have not tried that as I have no need to use aggressive cancellation anymore.

bugs.digium.com/view.php?id=2820

bugs.digium.com/view.php?id=4823


#7

Hi,

Are those patches not for when you go VOIP to PSTN in your Asterisk?

In my case there is no VOIP to PSTN apart from the termination in VoipJet’s network.

I think this is an issue caused by my iax configuration against VoipJet or and issue caused by VoipJet. What I base this on is:

  1. All my voip phones have the same issue with VoipJet (soft and hard phones).
  2. The issue doesn’t exist with FWD (they terminate 800 numbers for free)

Now I have searched a lot and not found anything apart from this thread. Does that mean that nobody else has this issue?

Again, the symptom is this:

  1. If there is a moment of silence, the line goes dead. You don’t hear anyting. It opens up around 1 second after somebody starts talking.

  2. If you accidently interrupt the other guy on the line, his/her voice goes dead while you are talking and wont come back until 1 second after you have stopped talking. This is like it was no full duplex or something.

Bullet 2 is the most irritating. The other person on the line have the same experience.

// Jonas


#8

I’m of the same opinion as ehsjoar,

we exactly experiene the same problem and more and more i think that the problem is caused because of the iax.conf. i think that there must be a mismatch with voipjet.

so, if someone has a working iax.conf without silence, it would be really nice if he can show it to me. (witout account information :smile: )

And there is another mysterious point:
When i call my ISDN-phone or mobile there is a continious stream of data. there is no silence. Only my ip-phone experiences the silence.

@ mustardman
I don’t use asterisk very long. How can i install these patches?

MArpi


#9

[quote=“MArpi”]I’m of the same opinion as ehsjoar,

we exactly experiene the same problem and more and more i think that the problem is caused because of the iax.conf. i think that there must be a mismatch with voipjet.

so, if someone has a working iax.conf without silence, it would be really nice if he can show it to me. (witout account information :smile: )

And there is another mysterious point:
When i call my ISDN-phone or mobile there is a continious stream of data. there is no silence. Only my ip-phone experiences the silence.

@ mustardman
I don’t use asterisk very long. How can i install these patches?

MArpi[/quote]

Download to /usr/src/zaptel
Re Compile zaptel driver
#/usr/src/zaptel/make clean
#/usr/src/zaptel/make install

Reboot Linux