SIP noise / echo


#1

Hi,

I’ve setup a simple Asterisk server using 3 Sipura SPA-841 SIP phones, and 2 POTS lines using 2 X100P FXO ZAP cards. We’re not doing any external VOIP.

When I use only the POTS lines, I have crystal clear sound everywhere (IVR, MOH, Voicemail, even if I dial in over one line and back out on the other).

However, when I use any of the SIP phones (SIP to SIP, ZAP to SIP, or SIP to ZAP), the connection is noisy with static and jitter, and echo is just horrible.

Everything I can find in the various FAQs would make me think that SIP to SIP on a quiet network should be the easiest setup. I can’t seem to find any settings to adjust either, because all of the echo cancellation stuff is for ZAP, which seems to be fine.

I’ve tried all kinds of stuff - changing cables, hubs, server nic, etc. I thought it might be something to do with my install, so I tried both a Xorcom Radpid install and a full-compile standard build. The Xorcom one actually seems silghtly better for some reason, but the problem is still there. I’m running this on an old PII/266, 384MB RAM, 2GB HDD - but I’m barely at 5% CPU and 40% RAM usage even when all lines are active and MOH is going.

Does anyone have any ideas? Perhaps something on the phones I can change? I’ve already upgraded to the latest firmware, and verified that I’m using the ulaw codec (should I force something else?).

Thanks,

Matt


#2

Do you have “silence suppression” turned on in the analog adapters? That doesn’t work so well with Asterisk. Strangely, it works best when the silence is transmitted too.


#3

Nope. Not in zapata.conf. I can’t even find anything that resembles a silence supression setting except in phone.conf - which I think is ignored unless you’re using local linux telephony devices like /dev/phone0.

Besides, the problem is clearly with the digital SIP channels. The analog ZAP channels work great until I connect to a SIP channel, and SIP channels don’t work well even when ZAP is out of the picture.


#4

Are the SIP phones softphones? If they are, that would explain it.


#5

Many softphones and hard phones have a silence suppression setting, so be sure to check there too.

A couple I’ve found even make it default.

Since you’re using the 841’s be sure you use the latest firmware. There were a couple with bad audio. Specifically 3.1.3(a).

sipura.com/support/index.htm

You’re also running this on an old PII. I bet the network connection isn’t full duplex. You’ll want a full duplex network connection to keep the audio steady.

Also be sure your interrupts are not conflicting. If your network connection is sharing an interrupt with something in the system, your processor is going to have to try to make time for both system objects.