Able to call normal ground phones but not mobiles


#1

Hi everybody,
I have setup am Asterisk Box using a Digium Card TE110P. It works very well except calls to mobiles (starting with 3) are not done, while other calls (starting with 0) are regularly answered. The dial plan is:

[general]
static=yes
writeprotect=no

[home]

exten => _2xxx,1,Ringing
exten => _2xxx,2,Wait(2)
exten => _2xxx,3,Dial(SIP/${EXTEN},15,tT)
exten => _2xxx,4,Voicemail(u${EXTEN})
exten => _2xxx,5,Hangup
exten => _2xxx,104,Voicemail(b${EXTEN})
exten => _2xxx,105,Hangup

exten => _[013].,1,NoOpe(${EXTEN})
exten => _[013].,2,Dial(ZAP/g1/${EXTEN}@inbound)

;Number that the IP Phones dial to access voice mail
exten => 9999,1,VoiceMailMain(s${CALLERIDNUM})
exten => 9999,2,Wait(3)
exten => 9999,3,Hangup

;[inbound]

exten => _651123[0-8]xx,1,Ringing
exten => _651123[0-8]xx,2,Wait(2)
exten => _651123[0-8]xx,3,Dial(SIP/2${EXTEN:-3},10,t)
exten => _651123[0-8]xx,4,Voicemail(u2${EXTEN:-3})
exten => _651123[0-8]xx,5,Hangup
exten => _651123[0-8]xx,104,Voicemail(b2${EXTEN:-3})
exten => _651123[0-8]xx,105,Hangup


while debug during call is :

linuxCLI>
– Executing NoOp(“SIP/2000-6850”, “3487024125”) in new stack
– Executing Dial(“SIP/2000-6850”, “ZAP/g1/3487024125”) in new stack
– Called g1/3487024125
– Zap/1-1 is making progress passing it to SIP/2000-6850
– Channel 0/1, span 1 got hangup
– Hungup ‘Zap/1-1’
== No one is available to answer at this time
Aug 23 17:03:07 WARNING[6876]: pbx.c:1948 ast_pbx_run: Timeout, but no rule ‘t’ in context ‘home’
– Executing NoOp(“SIP/2000-6396”, “03487024125”) in new stack
– Executing Dial(“SIP/2000-6396”, “ZAP/g1/03487024125”) in new stack
– Called g1/03487024125
– Zap/1-1 is making progress passing it to SIP/2000-6396
– Channel 0/1, span 1 got hangup
– Hungup ‘Zap/1-1’
== No one is available to answer at this time
Aug 23 17:04:00 WARNING[6876]: pbx.c:1948 ast_pbx_run: Timeout, but no rule ‘t’ in context 'home’
linux
CLI>


The mobile was not ringing…

Best regards and thank you

Mauro Zanin