3Com Asterisk

Is this the place to discuss the now-orphaned 3Com Asterisk switch?

How do you reset the voicemail system so that it stops asking for a new password every time you access the voicemail system? Thanks in advance.

Well, OK, I suppose like anything else in life, I’ll just figure it out by myself after a couple of days of being ignored. So I find an obscure note in a 3Com release note that says that when you change the password to something other than the voicemailbox number, it will stop asking for you to change it.

So back to my previous question - how do I get info about the 3Com AA50 device now that 3Com has offically orphaned it?

Like how do I delete voicemail messages on a 3Com AA50 that thinks its RAMFS should be read-only?


3com.com/swd/jsp/user/result … =3CR10551A

seems to have a manual listed.

It doe look like a “standardish” AA50 though


Yeah, I’ve got that stuff already. Thanks for the pointer any way. The 3Com device is “just” an AA50, but the Digium tech that I spoke to a while ago told me that it is “different”. Now I know it has a few minor customizations (changed Comedian Mail to 3Com Mail), but it appears to be basically the same hardware and mostly the same firmware.

So I spent two entire days pulling out what’s left of my hair without getting this device to be able to dial out an analog line. The manuals are not hardly useful (the secret of my success for over thirty years has been that I actually read manuals. Unlike most other software engineers that I know), and although this is supposed to be an “appliance”, as in “plug it in and it works”, nothing seems to be further from the truth.

If anyone has experience with this 3Com device (or the AA50 Appliance) I’d be delighted to correspond with you.

It’s been somewhat over a week now, and the response is deafening me.

So in the pursuit of figuring it out on my own, I’ve come to an interesting conclusion. I now believe that it is NOT possible for an experienced IT professional to configure a Digium AA50 (or its 3Com counterpart) to actually connect to an FXO or SIP line WITHOUT some secret information that is provided by Digium Tech Support (3Com no longer has tech support for this orphaned device) ONLY to owners of new devices that include the SUPPORT PLAN. And they don’t sell support plans to buyers of used equipment.

I’ve come to this conclusion after hours of reading both the Digium AA50 Admin Manual and the 3Com Admin Manual. There is not sufficient information in these manuals to configure the device to connect to the outside world. There are many (many!) undocumented screens in the Asterisk GUI that all manipulate the .conf files in fragmented ways. By “undocumented”, I mean “does not appear in the Digium or 3Com manuals.” And when I use PuTTY and vi to edit the .conf files directly, the GUI changes them back under the covers.

And when I call Digium Tech support, they refuse to talk to me about this, insisting that the 3Com appliance “is not a Digium product.” Despite the fact that the system identifies itself as a Digium product in its firmware.

So I asked Tech Support if the would sell me a support contract if I bough a used AA50 with their brand on it. Surprisingly, the answer was “NO”.

Buyers beware - apparently it’s a great business strategy to earn love in the world by giving away free software as a marketing strategy, but carefully hiding information for a closed system as a commercial product. learn from my mistakes and understand that a great deal on a used commercial version is no deal at all.

I’ll be continuing the expedition into the 3Com device this coming week, so if anyone else finds themselves stuck in this situation, drop me a line.


I know the feeling. Not a regular here, but it seems to be the only place to get real help for Asterisk. I have a couple of questions, so trying to build up Karma I answer what I can.

There are two settings in the voicemail.conf that cause this along with the voicemail secret being set to the extension.

FORCENAME and FORCEGREETINGS. If you could get those set to ‘no’ I would think it would stop. Other than that, changing the voicemail password to not be the extensions would surely be effective.

It has to be the lack of documentation that is killing you more than anything else. It is based on Asterisk, so it is most certainly possible IF the configuration files were correct…

This is because the Asterisk GUI, PiaF, Trixbox, etc. all blow monkey chunks. I gave up and went to bare Asterisk and wrote every single line of my configuration files by hand. Went Realtime for most of it, and when absolutely necessary created an API running on the box that I could run functions against it to update the configuration files.

Trying to understand how the GUI affects the configuration file is like looking at a wall of thousands of multi-color lights, pressing one of them, and watching the rest to see what they do. I feel that if I was an idiot savant who could verify large prime numbers in his head while muttering, “It’s Astrooonomical”, I might have a chance.

It does not help that the GUI removes all your custom modifications either. I know at least in the case of Trixbox, there are custom configuration files that will hold your modifications.

I still have to manage a few Trixboxes, which I am not happy about, and from my experience in the screens it is not about entering information into the fields that would think is correct. It’s about what you leave missing.

Huh? Yeah, I know. Counter intuitive. Even though the field exists to put data into, doing so gives you an unsuccessful result.

I would suggest seeing if you can locate any custom configuration areas that the GUI won’t smash to pieces and go from there as I have no real idea what the screens are really doing in the configuration file and I doubt it is based on Trixbox.


I forgot to add you might want to evaluate how much your time is worth if this is for business. You can get fairly inexpensive FXO/FXS cards these days (if you really really need them anyways) and construct a pretty decent Asterisk box from commodity hardware. I would think for $750 - $1000 dollars you could get everything you wanted out of this 3COM device and either sell it to some other sucker, or more preferably, use it for target practice.

The greatest IT lesson I have learned so far is when to give up and choose a different path to the solve the problem and provide the service.

If this is for personal reasons, then by all means don’t give up to you make that little $%( do exactly what you want :smile:

It’s great to know that there is someone actually looking at this, thanks. I already figured out the password thing but your answer is very succinct. More Karma to you.

Regarding the GUI and configs, the appliance version runs on UClinux on an embedded Blackfin DSP as its CPU. The weirdnesses come from the Flash-based file system that runs on a RAMdisk during operation. So all the know-how from the standard open source distribution does not apply here. I’m thinking of attempting to operate the box from a cold reset without ever using the GUI, but I don’t think that is possible - the GUI is need to enable the DropBear SSH before I can log in with PuTTY. But maybe if I do that and then use vi without ever going back to the GUI it might work.

Current strategies have to do with disassembling previous configs that were backed up to Flash by the previous owner. But when they are restored, the passwords all change. Naturally. I thought I had it beat when I downloaded the backups to a PC and opened them (tar files) and copied the password file from a backup with my config into the tar file, replacing the one with the unknown password. But when I then tried to upload that backup file it did not restore. I’m not sure that restore by upload actually works with the GUI anyway.

A progress report: So the 3Com AA50 is actually working. Somewhat. But I don’t know why. I did manage to crack the password on one of the backups from the previous owner and then get it uploaded. And now I can place and receive calls with two Zaptel lines. But if I try to change the configuration and shut off the third analog line, it stops working. The journey continues …

And now another status update. So I’ve been able to get the 3Com AA50 up and running despite the lack of any perceptible support from Digium, the folks who deny that this is their product and tell me to call 3Com for support. The funny part is that there is no 3Com any more. The unfunny part is when I “cat /etc/version” it says “Digium.S800I Version 3.1.0 – Thu Jul 10 18:28:21 IST 2008”. The sad part is that this orphan is merely two years old and already abandoned by its maker.

All that having been said, I have it working, and am willing to provide a TGZ of a working config on request to others that are trying to get the 3Com version working with Broadvoice.

Now, the latest mystery. So I find that some of my extensions have left-over voicemail messages from the previous owners of the system. And when I try to delete them, the system complains that it is a Read-Only filesystem and won’t let me. The reason this is a mystery is that when I reboot, “mount” shows that the /dev/hda1 mounted on /ramfs is RW, just as you would expect. And when I navigate to the Sounds/voicemail directory it is still RW. But as soon as I try to rm any of the VM files, it immediately becomes RO. I’m curious if anyone can explain why it does this.


All this might be a clue as to why 3Com doesnt support it anymore. You know that when people read things where people are complaining about a product and whining because no one is helping them, doesnt really make them want to answer you. First of all it is an appliance that runs some sort of asterisk that is old, with a gui made by 3com, you cant just edit the conf files when there is a gui involved. Things will not work properly then. The gui depends on the fact that it will be editing the files. How can you expect digium to support something that was rebranded? Digium has no clue what was changed and how…The Amanda Company also has an asterisk based product but I can guarantee that I cannot get support from Digium. The real reason no one was able to help you is that maybe…no one has worked on that device before? Sure…some have worked on the AA50 but they are similar not the same…Most of the people that visit this site build their own machines install asterisk themselves and work on it themselves. Now its great you have figured things out, and want to help others with it. Ok, now that you have a working system(well sort of) have you tried deleting the mailboxes and extensions, then re-adding them and seeing if your problems go away? In alot of proprietary systems I try that first and usually it works. Some systems have issues with voicemail when you change the extensions name while it has voicemails left in the box…Its worth a shot anyway…
Good luck and you can post here but just remember that alot of people probably havent worked on the 3com product line…

I appreciate that you are taking the time to ponder and comment on my situation. Since that last message, I have learned many more things. The GUI on this thing is called “Asterisk GUI”, happens to be the one that was developed for AsteriskNow. And I’ve already read the chapter in Asterisk:the future of Telephony on Asterisk GUI which appears to be about all the information on the planet other than the *GUI source code.

I understand that 3Com made changes to the system. And I understand that the hardware is the older revision of the current Digium AA50, with the exception that the current AA50 has echo-cancellation hardware. But the only real changes that 3Com made were in the automatic provisioning of their own brand phones. And Polycomm.

A number of these little Blackfin-based 3com-versioned offspring of Digium are appearing regularly on eBay, with some of them selling for less than $200. Including one dealer lot of new unopened 3Com product that went for $200 apiece. Seems to me to be a nice small business solution/opportunity if they can be induced to work.

And as for any Digium assertions that deny the paternity of this 3Com device - there is an Asian vendor (perhaps was 3Com’s manufacturer?) selling them as new with the latest versions of the AA50 firmware installed. They offered to remotely flash my system with the newest Digium firmware for a fee. So much for any claims that the hardware was somehow changed by the addition of the 3Com logo on the case.