1.4.1 CDR csv creation problem

versus 1.2.x
Master.csv is now in …/cdr-custom why?

and I was using accountcodes in 1.2.x and creating individual customer csv CDR files in …/cdr-csv

but I cannot make this happen in 1.4.1
i used all my old .conf files from 1.2.10 with the new 1.4.1 install

I have cdr_csv.so loaded

I this a bug or something new to config…
or what have I overlooked.


Gee… thanks 1.4 developers for making something un-obvious…
and many thanks to this post… I may have working CDRs again.

How to enable CDR-CSV logging in Asterisk 1.4.0
« am: Samstag, 24.02.2007 12:37 »

Starting CDR-CSV-Logging in a default installation of Asterisk 1.4.0 takes some additional steps that are neither documented nor obvious. Out of the box, Asterisk will update:

but not the default CSV File:

To start csv-logging into this file, you must edit /etc/asterisk/cdr.conf, remove the semicolon preceding [cdr] and also uncomment at least one of the following lines:

;usegmtime=yes ;log date/time in GMT
;loguniqueid=yes ;log uniqueid
,loguserfield=yes ;log user field

The parameter value is not important, it may be set to no, but it seems there must be at least one entry in the [cdr] section in order to start cdr-logging.

I know answering to yourself may see pointless at times.
But in this case I am VERY thankful that you pointed this out, I was having lots of trouble getting this to work due to an empty cdr.conf.

I got the 1.4 sample and edited it, now it works just fine.
So thanks for taking the time to update this post, it really helped me.

We spend many frustrating hours on this problem and one very important step has been left out. The modules.conf file must explicitly load the cdr_csv.so module!! This was an entry that was not required in v1.2 and that the developers have failed to note in any documentation that we’ve found.

If anyone is still having problems with CDR logging to a csv file, the be sure to add the following in your modules.conf file:

load => cdr_csv.so

An explicit load of this module should not be required.


Pete Howell
Mecca Hosting - Fast, Reliable, Secure Websites


I am trying to fetch or atleast view CDR record in Master.csv
When i run command ld in cdr-csv directory,it shows nothing.

How can i view CDR data?