Okay, I’ve stepped into another pile of it…tried to setup a conference room but keep getting an “invalid conference room” error message.

The CLI screen shows:

-- Executing MeetMe("SIP/2000-e1b6", "1234|i|5678") in new stack

== Parsing ‘/usr/local/etc/asterisk/meetme.conf’: Found
Jul 10 20:53:17 WARNING[9724]: chan_zap.c:916 zt_open: Unable to open ‘/dev/zap/pseudo’: No such file or directory
Jul 10 20:53:17 ERROR[9724]: chan_zap.c:7444 chandup: Unable to dup channel: No such file or directory
Jul 10 20:53:17 WARNING[9724]: app_meetme.c:464 build_conf: Unable to open pseudo channel - trying device
Jul 10 20:53:17 WARNING[9724]: app_meetme.c:467 build_conf: Unable to open pseudo device
– Playing ‘conf-invalid’ (language ‘en’)
== Spawn extension (default, 1234, 1) exited non-zero on ‘SIP/2000-e1b6’

I’m sure zaptel was installed…at least it says it’s already installed when I try to install it. So what do I need to do to get the conference rooms working?


You have to load the kernel driver,

You have an axample in /usr/local/etc/rc.d/zaptel.sh.sample

You have to add a line like:
/sbin/kldload ${LIBDIR}/ztdummy.ko || exit 1

And don’t stop the zaptel driver while asterisk runs,
my machine just freezed when I tried that. Bah… :frowning:

Johan Wilfer

Or if you are running a later version, just add the ztdummy to the load and unload ines in your /usr/local/etc/rc.d/zaptel.sh

The lines should the look like this (added part in bold):

kmod_load="zaptel.ko ztdummy.ko qozap.ko wcfxo.ko wcfxs.ko wct1xxp.ko wct4xxp.ko wcte11xp.ko"
kmod_unload=“wcte11xp.ko wct4xxp.ko wct1xxp.ko wcfxs.ko wcfxo.ko qozap.ko ztdummy.ko zaptel.ko”