Zaptel stopped working

I lost power to my box today due to bad weather. When it booted back up Asterisk was working but my TDM400P card isn’t. I looked in to it and the zaptel driver wasn’t loaded. I tried to load it but it said it couldn’t find it.

[root@australia zaptel]# modprobe zaptel FATAL: Module zaptel not found.
I’m running Centos 5. So I ran

[root@australia zaptel]# find /lib/modules | grep zaptel /lib/modules/2.6.18-8.1.4.el5/misc/zaptel.ko
then ran

[root@australia zaptel]# uname -r 2.6.18-8.1.8.el5
It looks like a new kernel update was installed and now my zaptel driver is in the wrong place. I went back to my zaptel directory and tried to recompile it. Make runs fine but when I run make install I get the following error:

make[1]: Entering directory `/usr/src/kernels/2.6.18-8.1.8.el5-i686' mkdir: `/lib/modules/2.6.18-8.1.8.el5/misc' exists but is not a directory make[1]: *** [_emodinst_] Error 1 make[1]: Leaving directory `/usr/src/kernels/2.6.18-8.1.8.el5-i686' make: *** [install-modules] Error 2
I checked and misc is there but it is a compiled file not a directory. I’m stuck anyone have any ideas? Thanks for any help.

I’d try deleting the’misc’ file and create the directory in it’s place, then run the install again.

I’ve just had a look on a Centos 5 box (without zaptel) and there is no misc file, so I guess one of the installer scripts on your system has a bug and created the file in place of a directory.


Why didnt you just edit grub so it loaded the kernel you wanted ?
I have seen this problem many times where owners upgrade the kernel and dont realise that zaptel is complied agaist a specific kernel.


Thanks rjenkin, that got it. I thought I could do that but I wanted to make sure that there wasn’t a new kernel feature I was aware of. I am back up and running now.

Also thanks for the tip ianplain, I was going to go that route if I could figure it out.