Zaptel not seeing kernel source, Fedora 5

While attempting to install zaptel an error was reported that no kernel source is present:
#cd /usr/src/zaptel
make clean
/some text about activity of “make clean”, no erors reported/
/activity during make. At the end, the following error is reported:
"You do not appear to have the sources for the 2.6.15-1.2054_FC5 kernel installed. make: *** [linux 26] Error
Although prevoiusly downloaded and installed kernel source via RPM from Fedora web site:
#rpm -ivh kernel-2.6.15-1.1955_FC5.src.rpm
and after:
#rpmbuild -bp --target=noarch /usr/src/redhat/SPECS/kernel-2.6.spec
Done all this as a root on Fedora Core 5 machine, directory structure of usr:
/usr/src/redhat/BUILDS, RPMS,SOURCES, SPECS, SRPMS… the BUILD directory contains kernel-2.6.15/linux-2.6.15/arch, block, crypto, Documentation, drivers directories…
Is the kernel source located in a wrong directory so zaptel can’t find it? How is this to be repaired?

I think you need to do a “make linux26” not just “make”.

Even after “make linux26” I get the same error message…

Did you install the kernel source when you set up the box? I’ve found Red Hat Distro’s notoriously bad about including kernel source. That’s a set of packages I’ve specifically had to select at install time.

  1. ensure you do in fact have the kernel source. If not, download it using rpm/yum/whichever you prefer

  2. Once you have the correct Kernel source for your version of the kernel, make sure you have that source linked in the /usr/src/ or whatever your zaptel base install directory is see: … stallation

  3. fix the Kernel Source typo problem

  4. got back to make clean and start again.

  5. don’t forget to recompile astrisk afterwards.

I am a bit of a newb when it comes to working with Red Hat. I am having the same problem. When I do 'Make clean" for Zaptel-1.2.6 I get [clean] Error 2. The line before that, it says “/lib/modules/2.6.16-1.2122_FC5/build: No such file or directory. Stop.”

I went to /lib/modules/2.6.16-1.2122_FC5 and realized that there is a broken link pointing to “…/…/…/usr/src/kernels/2.6.16-1.2122_FC5-x86_64” When I went to /usr/src/kernels I realized that there was a directory there called 2.6.16-1.2080_FC5-x86_64. I renamed that directory to …/2.6.16-1.2122_FC5-x86_64 and I was able to clean, make, and install Zaptel.

Since I’m new to Linux, I’m not sure what the repurcussions of what I did are, but I’ll let you guys know.

mraley, when setting up the box there wasn’t any option for installing kernel source.
Looks like I need only kernel headers, since I guess zaptel is yet another driver. So I downloaded and rpm’d the kernel-devel package but problem with zaptel reporting missing kernel source persists:
#cd usr/src
#rpm -ivh kernel-devel-2.6.15-1.2054_FC5.i586.rpm
and then same warning appears about missing header V3 DSA signature.
Decided to ignore the warning and proceeded to untaring zaptel but on install-time the same message about missing kernel source appeared.
Am really wondering if ANYONE else got FC5 to work with zaptel and what is to be done about kernel headers and zaptel not seeing them.

It took me a while to get things running smoothly, although the path to success can be very short with some direction.

I recommend for all FC5 users to do the following and confirm whether it works or not:

Those 2 updates will update the kernel to the latest along with the necessary sources and linking, etc.
yum install kernel
yum install kernel-devel
reboot into the new kernel (in my case, the upgrade was from 2.6.15-1.2054_FC5 to 2.6.16-1.2122_FC5 (you can check with uname -r)

Now go ahead and compile zaptel again. All should work fine. No need to modify any other files. If you have an problem, please reply back.

upgrading kernel, kernel-devel and rebooting worked for me.

OK guys, so how do you upgrade the kernel without yum and connection to Internet from Linux box?
Sorry for asking this, but am sucha linux newbie…

Hi ubaggili,

I did exactly as you mentioned. See below error:

You do not appear to have the sources for the 2.6.17-1.2139_FC5smp kernel installed.
make: *** [linux26] Error 1
[root@asterisk1 zaptel-1.2.6]# uname -r
[root@asterisk1 zaptel-1.2.6]#

do i need to do any additional updates?

thanks in advance.


Please post the outcome of the following commands:

rpm -q kernel

rpm -q kernel-devel


uname -r


Hi ubaggili,

Thanks the quick reply,
here is the output requested.

You do not appear to have the sources for the 2.6.17-1.2139_FC5smp kernel installed.
make: *** [linux26] Error 1
[root@fedora zaptel-1.2.6]# rpm -q kernel
[root@fedora zaptel-1.2.6]# rpm -q kernel-devel
[root@fedora zaptel-1.2.6]# uname -r
[root@fedora zaptel-1.2.6]#

Please let me know what could be wrong.


Do not forget that you must have the source of the running kernel… I would suggest download the source (for FC there might be a .rpm file which contains the source of the kernel you want to install) and then compile this source.

Once compiled, just intall and add your second and own compiled kernel to the list of system kernel in order to use it at boot time.

Spaquet: I am able to compile with just the kernel-devel package installed. I have done it just about 10 times in the last month… I’m not totally convinced that one needs the sources…

Sekhar: I’m curious about the order you ran the Yum commands I listed:

Did you run them in the specified order?

Did you reboot after u installed the 2 packages?

If the answer is yes to the above, here is what I’d like you to do:
1- yum remove kernel-devel
2- yum install kernel-devel
make; make install for libpri
then, make; make install for zaptel

Please try this in the exact order that is specified, and let us know what you find.


You do not appear to have the sources for the 2.6.17-1.2139_FC5smp kernel installed.
make: *** [linux26] Error 1

Please let me know what could be wrong.[/quote]

On Fedora 5, the symlink /lib/modules//build is pointing to the wrong directory:

  1. cd /lib/modules/uname -r
  2. ll (that’s two L’s)
  3. rm build
  4. ln -s /usr/src/kernels/YOUR VERSION OF THE KERNEL build
  5. ll
  6. cd /usr/src/zaptel
  7. make clean
  8. make linux26 (don’t know if “make linux” is bad or what)

Hope that helps

Hi All,

I know these messages are all a little old now, but…
I am having the same problem as specified in this post and many others.

I have got the error
You do not appear to have the sources for the 2.6.17-1.2139_FC5smp kernel installed
make: *** [linux26] Error 1

I have followed all the advice on this forum, even to the point of downloading and recompiling the latest kernel, I think I did it right…
I am however still getting this error.

I am V new to Linux…so I don’t even know the basics, have to look up even what ll meant.

can anyone give me some tips on
A. Checking the kernel installed and loading is the latest one (
B. Directing Zaptel to this new kernel instead of the old one
C. anything else?

Thank you in advance

Ihave tried FredTheMans suggestions, also the yum install kernel-devel, and yum remove stuff…i am lost…

[quote=“cclambie”]You do not appear to have the sources for the 2.6.17-1.2139_FC5smp kernel installed
it still can’t find the kernel sourcode for the kernel you have installed. when you installed your current kernel, did you download and compile from source, or was it a package manager ? if the latter try using the same package manager to install “kernel-sourcecode”. you will proably get a multi options error back, but then you can append # and your kernel version to get the right one.

To determine if your machine hardware is one of i386,i586,i686 type :-
uname -a

Then download the appropriate kernel and kernel-devel rpms(not source rpms) from … es/5/i386/

and upgrade the existing packages with

rpm -Uvh [package-name]

ok, thanks for the quick responce:

baconbuttie - I downloaded and installed the source from the source, no packages where used (I think - no rpm was used?)

vinod.vijayan -
the results
[root@localhost mail]# uname -a
Linux localhost.localdomain 2.6.17-1.2139_FC5smp #1 SMP Fri Jun 23 13:12:06 EDT 2006 i686 i686 i386 GNU/Linux

what would be the most appropriate source for this?

I don’t really get this whole linux thing yet as a hard core windows, but I am willing to be converted…I am really. Thank you for your patience if I ask some blatently obvious question about linux…I am but a mere windows geek.

You can always use yum to download the package for you, makes life a little simpler.