Zaptel fail to compile on Red Hat

Hello guys,

I am tired for try to do this. Has been not possible to compile Zaptel on my Red Hat system.
I am using kernel 2.6.9-34.EL-i686 and try to set a TDM400 Digium with 1FXO and 1 FXS
Can not to compile zaptel. I tried with version 1.2.13 and version 1.4.0-beta2 but with the same problem. All the symbolic links to kernel source are present.
The problem is as follow:
[root@localhost zaptel-1.4.0-beta2]# make install
make[1]: Entering directory /usr/src/zaptel-1.4.0-beta2/menuselect' make[2]: Entering directory/usr/src/zaptel-1.4.0-beta2/menuselect’
make[2]: menuselect' is up to date. make[2]: Leaving directory/usr/src/zaptel-1.4.0-beta2/menuselect’
make[1]: Leaving directory /usr/src/zaptel-1.4.0-beta2/menuselect' make[1]: Entering directory/usr/src/zaptel-1.4.0-beta2’
make[2]: Entering directory /usr/src/zaptel-1.4.0-beta2/menuselect' make[3]: Entering directory/usr/src/zaptel-1.4.0-beta2/menuselect’
make[3]: menuselect' is up to date. make[3]: Leaving directory/usr/src/zaptel-1.4.0-beta2/menuselect’
make[2]: Leaving directory /usr/src/zaptel-1.4.0-beta2/menuselect' make -C /lib/modules/2.6.9-34.EL/build SUBDIRS=/usr/src/zaptel-1.4.0-beta2 modules [[b]b]make[2]: Entering directory/usr/src/kernels/2.6.9-34.EL-i686’
CC [M] /usr/src/zaptel-1.4.0-beta2/torisa.o
/usr/src/zaptel-1.4.0-beta2/torisa.c:132: error: syntax error before “torisa”
/usr/src/zaptel-1.4.0-beta2/torisa.c:132: warning: type defaults to int' in declaration oftorisa’
/usr/src/zaptel-1.4.0-beta2/torisa.c:132: error: incompatible types in initialization
/usr/src/zaptel-1.4.0-beta2/torisa.c:132: error: initializer element is not constant
/usr/src/zaptel-1.4.0-beta2/torisa.c:132: warning: data definition has no type or storage class
/usr/src/zaptel-1.4.0-beta2/torisa.c:1143: warning: ‘set_tor_base’ defined but not used
make[3]: *** [/usr/src/zaptel-1.4.0-beta2/torisa.o] Error 1
make[2]: *** [module/usr/src/zaptel-1.4.0-beta2] Error 2
make[2]: Leaving directory /usr/src/kernels/2.6.9-34.EL-i686' make[1]: *** [linux26] Error 2 make[1]: Leaving directory/usr/src/zaptel-1.4.0-beta2’
make: *** [all] Error 2[/b][/b]

Is this Red Hat kernel version incompatible with zaptel?
I made all I could make.
Any tip?

I believe you need kernel headers also with zaptel-1.4

Angler,

Could you explain as you said “kernel headers”?
What it means?

It’s the kernel header files… You can fetch them with yum or up2date…

Do: yum install kernel-devel