Xlite3.0 @home & Asterisk @office behind firewall(solve)


i successfully register xlite 3.0(@ home w/ dynamic ip) to Asterisk box at office which is behind firewall(static ip not FQDN). the xlite is registered as local phone in which i can make direct calls to other ip phone in office LAN by dialing their local number. so its amazing to think that although im at home i belong to the local extesnsions at office.

now i would like to ask advice, suggestion and comments on how Xlite-3.0 could receive calls locally. (for instance i assigned local number for xlite the same length of digits to office local numbers.) when local phone at office dial the local number of my xlite she will be connected,

yes asterisk has outbound account only but id like to try local phone at office calling my xlite at home by not using that outbound account, is that possible?

or what else i need so xlite could receive that local call.

i can imagine this is quite possible as xlite able to call to office without any outbound sip provider. this make me think that asterisk could do in reverse but i dont know how.

please help and many thanks

If I understand it correctly, your Xlite registers to office Asterisk as an outbound-only extension. You’d like to know if you can register it so Asterisk can send you incoming calls. And you’d like all calls to your existing office extension to also ring your Xlite.

Now, if your extension is outbound-only (perhaps defined as a peer in sip.conf), Asterisk will not attempt to send calls to you.

However, there is nothing preventing you from registering Xlite also as an inbount extension (a user in sip.conf), or as a bidirectional one (a friend in sip.conf), provided you have control of configs.

I don’t know if it’s possible to register as exactly the same extension of your office phone. But you don’t need to, if you only want to receive calls based on existing extension.

There are many ways to do this. One is to put your Xlite’s in-bound (or bidirectional) registration in the ring group in the existing extension. You’ll get some harmless errors when your Xlite is not on. You may also use your office phone’s call forwarding to do this.

thanks for reply

but i have set my xlite as type=friend

and in sip.conf

note: asterisk has one LAN card

also i have another issue, when i have this setting at sip.conf
for realm,domain, externip and localnet
the sip clients in the office can not call each other (teh number is unavailable).

… i open udp 5060-5080 and 8000-20000 forwarded to my asterisk box
i can call from home and answer at office. whe i pick the i cannot hear from home but the home caller hearm. (confusing ah)

do i need to open ports from asterisk forward to firewall then to internet?
is so what port?

First things first :smile: If your Xlite is friend, then other people “should” be able to call it at xlite (the user name) - if they can input this. I doubt if ordinary SIP phones can do this easily, so the easiest way to verify would be to use another soft phone in the office (register as xlite1, for example), and dial “xlite”.

You’ll troubleshoot NAT/firewall issues only if you get errors from the above.

Another way to test is to change Xlite’s user name to something phonepad friendly like “12345”.

let me try that…

but i guess it doesnt matter
as i use the same process with other sip client
because in my dial plan i have this…


In this case, there must be some error messages? You can turn on SIP debug, etc., even use a sniffer to determine if any SIP attempt is made. If valid SIP are being sent, let’s come back to NAT/firewall stuff.

got it work sir.

i change rtp.conf

and in sip.conf

and in my firewall i forwarded port like this

and in xlite-3.0
domain=public ip of our firewall
click discover ip
and in stun i put the public ip of our firewall