XLite and PSTN Issue


#1

I have a very basic * setup with a 4 FXO port Digium card connected directly to 4 POTs lines.

My problem is this: when I place an outbound PSTN call (via a ZAP channel) from an XLite softphone I hear ringback. but once the called party picks up I can hear no audio, nor can the called party hear any audio. This happens no matter who I call in the PSTN world. I have found that if the called party answers in a sharp tone (seemingly at the right pitch) then the call will proceed normally with bi-directional audio. Otherwise the call seems to be tacked up, but no audio is getting to either phone. The key seems to be the pitch not volume.

If I place an outbound PSTN call from any of my SIP hard phones (snom, sipura and atcom models), the call works normally with no audio issues. If I call another phone on the LAN from the Xlite, the call is fine.

I have tried different headsets and a usb handset with Xlite. I have installed Xlite on another PC and tested it too. I also tried replacing the Digium card with another card. I have set the Xlite to transmit silence. I have tried enabling and disabling the callprogress setting in zapata.conf. Finally, I recompiled everything - zaptel, libpri and asterisk. However, nothing I have done has worked.

Anybody experience this before? At this point I’m open to any and all suggestions.

Thanks,
Sobel