Can not hear any sound in my asterisk


I am trying to connect my xlite through NAT. I hava a x-lite softphone which is in the same network with Asterisk server. ANd the other xlite softphone is in my friend’s house.

Both x-lite registrations are successfull. I can call each other.

Problem: We can not hear each other.

I have opened the following port in my home router and my friend’s homw as well:


I also have put the configuration of xlite as in the first page of this thread.
I have put STUN server as counterpath support suggest.
But it doesnot work

Can some 1 help me?

In you sip.conf you can set


this will make asterisk stay in the middle as a media server. It worked for me. Hope this helps

I have done canreinvite=no in all my extensions number which in sip.conf before. But it doesnot work.

Any idea?

Have you tried keeping an eye on the console screen whilst initiating these calls? No audio can also be the result of codec problems.

May be worth a try if you haven’t done so already.



Look in /etc/asterisk/rtp.conf and you will see rtpstart= 10000 - rtpend = 20000

If you dont forward these ports you wont get any voice.

Port 5060 I think is the port the call sip data goes on. Voice is always on the rtp ports.

You need to port forward 10000-20000 UDP from your router to your asterisk box.
You can set rtpend to a lower number ie 10500 so you dont forward so many ports.