X1o1P Does Not Hangup Calls

Asterisk 1.2.13 on FreeBSD-6.1, zaptel-1.0

I installed an X101P card and it works okay except that it seems to make the first call fine, but then the second call will not hangup. * appears to reconginze the call has terminated but the line to my wall outlet is still occupied. If I try to call this line it’s busy.

Any suggestions on what to do?

second call? you mean you make a call, then hang up, then make a second call and it breaks? That does sound odd, most likely a driver problem.

If by second call you mean makes a call, then while call 1 is going tries to make another call- this will not work. The X100 card is a 1-port card. The second port is a passthru for a telephone- the card is originally designed to be a modem. The second port lets you connect a desk phone which is disconnected when the modem uses the line.

I added the disconectsupervise setting as a previous post suggested but the problem still persisted. However, another search found that perhaps I was kldloading the drivers wrong. The old zaptel for freebsd used a file called zaptel.sh to load the drivers. By eliminating the use of this file and adding the line


to my /etc/rc.conf file, it seems to at least be settled down. It’s still not perfect. Several inbound calls worked fine. A few outbund calls worked but then an inbound call ended up getting hosed…but the line at least was not busy after this. I’m still testing.

I want to make this an official bitch…there was nothing in the zaptel docs that said to enable zaptel via rc.conf. It was only on a remote and obscure search that I found using altavista that I found this out. So for all you techs who are so quick to reply with RTFM…here’s one of the reasons so many novices get frustrated with that reply. I do run FreeBSD, not linux and my posts in the BSD forum as well as the mailing lists were not replied to with anything useful. RTFM is ambiguous at best.

[quote=“maxfiles”] for all you techs [/quote] Not that I was one. Well I guess there are not many in charge of supporting X100. I tried and retired a bunch of different clones. I guess I got what I paid for. Never used them in a serious way. For that, proper hardware is in order.