X101P Card not Configuring

I run FreeBSD-6.0 and *- I bought and installed an X101P card that I found from a supplier for a good price. When I installed this PCI card I was pleasantly surprised that FreeBSD found it on IRQ 9. So far so good.

I then followed the instructions in the TFOT manual on how to setup a zaptel channel. My zaptel.conf file is like so:


The TFOT manual said to reload the zaptel drivers which I did with the zaptel.sh file. Some really nice messages came up and it looked like I was on my way.

Zapata Telephony Interface Registered on major 196
Echo Canceller: MARK3
ZapTel device: vendor=e159 device=1 subvendor=8085
wcfxo0: port 0x6800-0x68ff mem 0xe4000000-0xe4000fff irq 9 at device 11.0 on pci0
ZapTel Attach for wcfxo0: deviceID : 0xe159
wcfxo0: [FAST]
wcfxo: DAA mode is 'FCC’
Found a Wildcard FXO: Wildcard X101P
ZapTel device loaded.
ztdummy: loaded

The kldstat command yielded this:


Id Refs Address Size Name
1 10 0xc0400000 63070c kernel
19 8 0xc1614000 31000 zaptel.ko
20 1 0xc1cbb000 7000 qozap.ko
21 1 0xc1647000 6000 wcfxo.ko
22 1 0xc1cc2000 a000 wcfxs.ko
23 1 0xc1ccc000 6000 wct1xxp.ko
24 1 0xc1d0d000 d000 wct4xxp.ko
25 1 0xc1cd9000 a000 wcte11xp.ko
26 1 0xc1655000 2000 ztdummy.ko

My conference rooms work so the timing with ztdummy is functioning. But when I run the zttool program I get a RED alarm.

Someone asked me to cat /dev/wcfxo0, so I did and got this. I assume the [off] keyword is critical here.

Wildcard X101P Board 1
Port #1 – FXO [off]

I tested the phone cable and it’s good, I then made sure I was plugged in to the “Line” port on the X101P card and I was. Still it’s a no go. Can anyone offer some more advice here?


What do you have in zapata.conf as well as run ztcfg -vvvvv and paste your resluts

I am using the generic copy of zapata.conf that came with the * install. I’ve played around with a few things in it but mostly left it the same. I also renamed this file and created the file that’s shown in the TFOT manual. Of course I adjusted it to work with channel 1 as I only have one card in the box.

ztcfg -vvvv produces this output:

Zaptel Configuration

Channel map:

0 channels configured.

I’ve double checked that I have the phone line in the right jack. The seller of the card has offered to refund my money or send me a replacement. I’m going to place this card in a FC5 machine to see if it’s a FreeBSD issue…which I’ve been suspicious of even before I bought it. FreeBSD and PCI cards usually don’t get along. Still I won’t be switching to Linux…

I want my…I want my BSD…!

I am half asleep so forgive me if I am wrong byt swtich fxsks to fxoks. Also based on the output of ztfcfg -vvvv, none of the channels are configured. Also are you sure you plugged in power to the card from the power supply ?