Won't Register on Startup, Must Touch iax.conf and Reload

To be sure, I rebooted my machine last night and checked it this morning. Ran iax2 show registry and I was not registered. Touched iax.conf and then reloaded and was registered instantly. Any help would be appreciated.

EDIT: Forgot to include some details…
Ubuntu 10.04.1 LTS (Linux 2.6.32-24-generic)
Teliax VOIP provider

what happens if you just restart asterisk? Did dit re-register at all (without the touch)?


Surprisingly, yes. I ran core restart now and was registered without any problems. Hmmmm… :question:

Hi I bet yo will find that

reload chan_iax2.so will also make it register, make sure you have qualify set as well

I think you can safely discount the touch from the equation and do one of the following:

verify your networking is not the issue (I.E. your router; for some reason [I guess experience] I always do this first as it was always the case in a past life)

turn on some sip debugging and watch the messages.

If David55 grabs this thread he can probably shed quite a bit of light on the messages…


then again so can ian…


I have qualify set, as well as nat. I’m no asterisk expert yet, so I couldn’t tell if that command was a typo or not, but I ran the following commands and they did NOT cause registration to work:
reload chan_iax2.so
reload chan_iax2

As far as networking it’s a simple setup. Everything is allowed out and TCP/UDP 4569 is forwarded to my asterisk box. I don’t think that’s the issue since it will register after a restart or touch&reload.

Possibly related, there are some warnings/notices when I run reload:

Connected to Asterisk currently running on tigas (pid = 1095) tigas*CLI> reload [Sep 15 15:17:53] WARNING[1845]: res_config_ldap.c:1591 parse_config: No directory user found, anonymous binding as default. [Sep 15 15:17:53] ERROR[1845]: res_config_ldap.c:1616 parse_config: No directory URL or host found. [Sep 15 15:17:53] NOTICE[1845]: res_config_ldap.c:1560 reload: Cannot reload LDAP RealTime driver. [Sep 15 15:17:53] NOTICE[1845]: pbx_ael.c:122 pbx_load_module: Starting AEL load process. [Sep 15 15:17:53] NOTICE[1845]: pbx_ael.c:135 pbx_load_module: AEL load process: parsed config file name '/etc/asterisk/extensions.ael'. [Sep 15 15:17:53] NOTICE[1845]: pbx_ael.c:138 pbx_load_module: AEL load process: checked config file name '/etc/asterisk/extensions.ael'. [Sep 15 15:17:53] NOTICE[1845]: pbx_ael.c:141 pbx_load_module: AEL load process: compiled config file name '/etc/asterisk/extensions.ael'. [Sep 15 15:17:53] NOTICE[1845]: pbx_ael.c:146 pbx_load_module: AEL load process: merged config file name '/etc/asterisk/extensions.ael'. [Sep 15 15:17:53] NOTICE[1845]: pbx_ael.c:149 pbx_load_module: AEL load process: verified config file name '/etc/asterisk/extensions.ael'. [Sep 15 15:17:53] NOTICE[1845]: app_meetme.c:6427 load_config: A reload of the SLA configuration has been requested and will be completed when the system is idle. [Sep 15 15:17:53] NOTICE[1845]: chan_skinny.c:7062 config_load: Configuring skinny from skinny.conf [Sep 15 15:17:53] NOTICE[1845]: app_queue.c:5660 reload_queue_rules: queuerules.conf has not changed since it was last loaded. Not taking any action. tigas*CLI>

As a workaround, I’m restarting Asterisk automatically on startup, although it won’t work unless I first pause for 60 seconds.


[code]# Pause for a minute, and then restart Asterisk

sleep 60
/etc/init.d/asterisk restart

exit 0[/code]