Wildcard TE121 (wcte12xp) driver is missing from current dahdi-linux?

Dear Friends
I’d like to build an Asterisk system under Debian 11 OS, with a TE121 (wcte12xp) PRI card, i followed the ‘tutorial’ :
but current (GitHub - asterisk/dahdi-linux: Mirror of official dahdi-linux repository. No pull requests here. This project is in the process of moving to Gerrit) tree do not support this hardware.
The README also do not mention this card. That’s very strange, because even the old BRI ISDN cards are listed, just not this particular type.
Unfortunately the debian built-in dahdi-dkms package can’t make VPMADT032 firmware. (i have that echo canceller DSP card attached to teh TE121 card)
Please help me, what can I do?
Thank You in advance!

Only Sangoma can make the firmware. As I remember it, even with the official source tree, it is downloaded, as binary, at install time, not included in the archive. Obviously Debian aren’t going to include that in the “free” repository.

Thank You David for informations.
Yes, you are absolutely right!
With dahdi-dkms method, dmesg says:

[ 49.087166] wcte12xp 0000:0b:08.0: Failed to find a registered loader after loading module.
[ 49.087171] wcte12xp 0000:0b:08.0: Failed to load VPMADT032 firmware.
[ 49.087375] wcte12xp 0000:0b:08.0: Failed VPMADT032 reset. VPMADT032 is disabled.
[ 49.087379] wcte12xp 0000:0b:08.0: Disabling VPMADT032 Checking.

And when I tried to install from source (/dahdi-linux-complete-2.11.1+2.11.1) I get the following error message:

/usr/src/linux-headers-5.10.0-14-common/Makefile:225: =============== ERROR ==============
/usr/src/linux-headers-5.10.0-14-common/Makefile:226: ‘SUBDIRS’ was removed in Linux 5.3
/usr/src/linux-headers-5.10.0-14-common/Makefile:227: Use ‘M=’ or ‘KBUILD_EXTMOD=’ instead
/usr/src/linux-headers-5.10.0-14-common/Makefile:228: ====================================

So this Bullseye Debian kernel version is too new. :slight_smile:
I will now try to build under oldstable (Debian 10).

Thank You!

You cold try download firmware from Digium.

Look for VPMADT032

Thank You for tip.
Yes i tried that, the problem was the newer kernel in Debian 11.
The github and the 3.x version dahdi-driver does not support the wcte12xp card! (don’t understand why)
The latest v.:2.x dahdi-linux driver (2.11.1) is rather old and does not compile on newer kernels unfortunately. I had to go back to debian version 9 (stretch), where everything works fine (kernel version 4.9.0).
Finally, it worked:
[ 20.244523] dahdi: Version: 2.11.1
[ 20.244924] dahdi: Telephony Interface Registered on major 196
[ 21.375147] wcte12xp 0000:0b:08.0: Setting up global serial parameters for E1
[ 21.558087] wcte12xp 0000:0b:08.0: Found a Wildcard TE121
[ 22.068267] dahdi_vpmadt032_loader: module license ‘Digium Commercial’ taints kernel.
[ 22.068270] Disabling lock debugging due to kernel taint
[ 22.271497] dahdi_devices pci:0000:0b:08.0: local span 1 is already assigned span 1
[ 26.520041] wcte12xp 0000:0b:08.0: Booting VPMADT032
[ 26.603863] wcte12xp 0000:0b:08.0: VPM present and operational (Firmware version 125)
[ 37.028967] wcte12xp 0000:0b:08.0: Span configured for CCS/HDB3/CRC4
[ 37.967331] wcte12xp 0000:0b:08.0: Setting yellow alarm


That sounds like one of the drivers that Sangoma removed, potentially?

If so, does it work on Debian 11 if you patch it back in, perhaps using something like this? GitHub - InterLinked1/phreakscript: A utility to automate the installation, maintenance, and debugging of Asterisk/DAHDI, while integrating additional patches to provide the richest telephony experience

If not, you might want to report an issue here for the DAHDI team: https://issues.asterisk.org

Thank You InterLinked!
I have never heard of this PhreakScript.
The readme mentions promising things, e.g. “Restores the “great purge” of DAHDI drivers that were removed in 2018 by Sangoma”
Thanks, I will look into it. Especially that it might include the asterisk patches that allow native firmware Cisco phones (CUCM) to work under SIP protocol. I’ve used the https://usecallmanager.nz patches so far, but this is interesting too. Thanks!

That is the actually the patch set in use for the Cisco stuff - it just pulls in the latest version automatically.

It comes with some new stuff of its own, but the main purpose is to automate installations which can sometimes be tricky.

1 Like

Sorry, I just noticed that there is the following option that I missed:
“–cisco install: Add full support for Cisco Call Manager phones (chan_sip only)”

Thanks InterLinked
I tried the script on debian 11 and indeed the wcte12xp driver works, it loads fine:
[ 54.116738] wcte12xp 0000:0b:08.0: Setting up global serial parameters for E1
[ 54.299527] wcte12xp 0000:0b:08.0: Found a Wildcard TE121
[ 55.020639] dahdi_vpmadt032_loader: module license ‘Digium Commercial’ taints kernel.
[ 55.020645] Disabling lock debugging due to kernel taint
[ 59.467588] wcte12xp 0000:0b:08.0: Booting VPMADT032
[ 59.563605] wcte12xp 0000:0b:08.0: VPM present and operational (Firmware version 125)
[ 70.249219] wcte12xp 0000:0b:08.0: Span configured for CCS/HDB3/CRC4
[ 71.175470] wcte12xp 0000:0b:08.0: Setting yellow alarm

However, I do not see the https://usecallmanager.nz sip patches.
I used the command:
phreaknet install --dahdi --drivers --sip

What “Cisco stuff” did you mean?
Thank YOu in advance!

Again, a problem occurred when I ran the following script:
phreaknet install --sip --cisco --sccp --cc 36

error: patch failed: channels/chan_sip.c:367
error: channels/chan_sip.c: patch does not apply
Failed to apply Gerrit patch 16569 (https://gerrit.asterisk.org/changes/asterisk~16569/revisions/5/patch?download)… this should be reported…

I tried with the https://usecallmanager.nz supported asterisk version too:
phreaknet install --sip --cisco --sccp --cc 36 --version 18.11.3

but the same error occurs.

If i try to apply the patch manually:
git apply --check 16569.diff
error: patch failed: channels/chan_sip.c:367
error: channels/chan_sip.c: patch does not apply

What could be the problem? Thank You!

Yes, the --cisco parameter is the right one for that.

–sccp is a Skinny/SCCP channel driver, probably not what you want (though it doesn’t hurt).
–sip enables chan_sip
–cisco adds the Cisco Call Manager patches

That patch it complains about is another chan_sip patch that conflicts with it. I’ve disabled it for now. Run phreaknet update and then try the command again. It should work.

That patch is incompatible with the --cisco option, so I will probably have to add a flag for that so they can coexist somehow.

Thank You InterLinked!
It really works now.
I have some 79xx SCCP phones and I want to experiment with them, so I wanted to install the SCCP channel. There are several 78xx phones that are SIP-only, so that is also required.
I’m just getting familiar with the SCCP channel, am I right in thinking that there is not really interoperability between SIP and SCCP within the same Asterisk installation? (e.g.: make a call from SIP to SCCP and vice versa)
Thank You!

I haven’t tried it, but I don’t know why it wouldn’t work.

SIP is SIP and SCCP is SCCP/Skinny. Two different, unrelated channel drivers. So they don’t interact with each other but you should be able to make calls between them with Asterisk just fine. If you can’t do that, then there’d be some kind of serous issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.