Where do I start?


#1

Hi all,

Need some help pointing me in the right direction. I have a fresh install of FC16, Asterisk 1.8.7.1, an x100P modem, and I have downloaded siptosis. My goal here is to be able to use Skype remotely to my home PBX which will then dial out from my home and allow me to proxy my home phone through Skype. There is a lot of information out there about how to setup Asterisk and I need some assistance sifting through it all. I’m not asking for an exact solution [and I’m not not asking :wink:] but I need to know where to start, I am willing to do the research, but just need guidance…

Thanks in advance for any information!


#2

Throw away Skype. You can no longer buy the Skype channel module from DIgium, and it wouldn’t have been supported by 1.8, anyway. Skype and open source do not go well together.

Also, I don’t believe that the X100P type voice modem cards are supported by dahdi. If they are, it will be legacy, unmaintained, code.


#3

Whilst I don’t know the actual reasons for the Skype channel module being abandoned, one obvious possibility is that Skype concluded that people were likely to not to use Skype-In or Skype-Out services, but actually use SIP for PSTN access, so there would be no revenue for Skype, beyond any initial licence fees.


#4

Wow OK, so does this leave me with any other options? Is there an alternative to Skype which has potential for what I’m looking to do?


#5

Depends what you are trying to do, but SIP, H.323, or IAX.


#6

Perhaps you can do something like what I do…

I have a VPN setup so the laptop can securely connect to my home network. While on the VPN, I can connect a soft phone to my Asterisk PBX. I make calls like I would at home. If I want the soft phone to ring for calls to my home, I just include it in the Dial(), or if using FreePBX, the ring group.

I have even used the laptop’s wireless for Internet and wired a hard phone, via cross over cable, to the laptop and registered the hard phone to the PBX. Worked pretty well considering how crappy the WiFi was.

Back to your original question, where to start? Here are my $.02

Get at least somewhat comfortable with Asterisk. I believe that the book is a pretty darn good place to start.
Try your x100p card to see if it works, I have no experience with it. I use the Digium cards. They work well and help support the project.
Once that is working. Setup a VPN. I like OpenVPN. there are others that could work for you.
Setup your remote connection and make some phone calls.
Learn lot’s of stuff along the way.
Share your knowledge to help others.


#7

Well after a few days of fighting I was finally able to accomplish my goal. I’m using my iPhone to establish an IPSEC VPN to my Cisco 2691 router then using the 3CX SIP phone for iPhone (free) I can now dial out through my home asterisk PBX. I’m glad I didn’t waste any time perusing Skype so thanks for that. The 3CX client even works through my vehicle’s Bluetooth just like normal calls. My asterisk PBX is running in a virtual machine too (ESXi 5) with my X100P card being passed through and Dahdi picked it up no problem. It all works better than I expected actually, even using my mobile providers 3G network to VPN and VOIP still sounds great with minimal delay.

I have only one obstacle left which I cannot seem to nail down. For the life of me I cannot get asterisk to start up automatically at boot. I have added it as a service so I can go ‘service asterisk start’, which will start but won’t work. I have copied the /contrib/init.d/rc.redhat.asterisk (modified to use /usr/sbin) to /etc/init.d/asterisk and made links in rc3.d and rc5.d but still won’t work. Also I’ve done the ‘chkconfig --add --level 35 /etc/init.d/asterisk’ but nada. If I start asterisk manually then I have no problems at all, even just simply typing ‘asterisk’ in shell and everything is up. If I try to start it via service or /etc/init.d/asterisk I will always get this message if I try to dial:

Oh dear… we couldn’t allocate a port for RTP instance
Failed to authenticate device “Xxxxxxxxxx”

asterisk starts fine but I can’t do anything with it. I’ve tried modifying the /etc/systemd/system/multi-user.target.wants to change the user it starts up as or run /usr/sbin/asterisk but nothing works like that. Only when I start it manually does it work. You would think this would be the easy part considering what’s already working here…


#8

Just do a source install and remember to run “make configs”. Do not try to run it non-root unless you are very familiar with your OS.