webRTC using sipml5 failed due to ssl connection error!


#1

hi everyone…
I’m trying to use webRTC in my local host. I did everything said in the wiki :slight_smile: https://wiki.asterisk.org/wiki/display/AST/WebRTC+tutorial+using+SIPML5

but when I try to access 127.0.0.1:8089/ws
asterisk CLI complians about ssl connection
from /var/logs/asterisk/messages :
[Sep 12 08:41:26] ERROR[7002]: tcptls.c:694 handle_tcptls_connection: Problem setting up ssl connection: error:00000001:lib(0):func(0):reason(1), Internal SSL error
[Sep 12 08:41:26] WARNING[7002]: tcptls.c:781 handle_tcptls_connection: FILE * open failed!

i tried https:/127.0.0.1:8089/ws and added it to the exception list ,
and now I see 404 page , asterisk
and when i want to use sipml5 demo https://www.doubango.org/sipml5/call.htm?svn=250
to make a sample call in expert mode I set WebSocket Server URL to wss://127.0.0.1:8089/ws
it just keep telling me : { Disconnected: Failed to connet to the server }

and when I change wss to ws in WebSocket Server URL the error changes to :
2:SecurityError: The operation is insecure.

I’m struggling with this for about 3 days and I don’t know what to do anymore, can anyone give me a hint ? :frowning:
thanks


#2

This means that there is no route to the host. But is better if you show us the complete debug from Firefox JS console. And be sure to allow the ports in your firewall not only webrtc also sip.


#3

thanks for the response, well turns out the problem was modules.conf
i had changed the modules.conf somehow and because of that some module(s) (I wonder which) did not load, so I was getting 404 on https://127.0.0.1:8089/ws ! and I guess that was the reason simpl5 couldn’t find a route to the host !

so that’s it ! it took me 3 days :expressionless: .
and now I have no Idea what to do next, I want to build a website and use webRTC features in it, but what should I do ? use sipml5 ? sip js ? or what ?! I don’t know what should I do now :D.


#4

WebRTC is not something you can just throw together and expect to work (despite what some things online portray). You need to learn about the underlying technology and how to debug things when it goes wrong (and it will). As for what to use - that’s up to you.


#5

HI team ,

Facing some issues while setting up

[Nov 24 14:32:09] ERROR[17029]: tcptls.c:694 handle_tcptls_connection: Problem setting up ssl connection: error:00000001:lib(0):func(0):reason(1), Internal SSL error
[Nov 24 14:32:09] WARNING[17029]: tcptls.c:781 handle_tcptls_connection: FILE * open failed!

My module.conf looks like this:

; Asterisk configuration file
;
; Module Loader configuration file
;

[modules]
autoload=yes
;
;
noload => pbx_gtkconsole.so
;load => pbx_gtkconsole.so
noload => pbx_kdeconsole.so
;
; Intercom application is obsoleted by
; chan_oss. Don’t load it.
;
noload => app_intercom.so
;
; Explicitly load the chan_modem.so early on to be sure
; it loads before any of the chan_modem_* 's afte rit
;
load => chan_modem.so
load => res_musiconhold.so
;
; Load either OSS or ALSA, not both
; By default, load OSS only (automatically) and do not load ALSA
;
noload => chan_alsa.so
;noload => chan_oss.so
;
; Module names listed in “global” section will have symbols globally
; exported to modules loaded after them.
;
[global]
chan_modem.so=yes

Please help…


#6

I’d start with the obvious and check the paths of your certificates in your configuration files. It looks like you may be missing a filename or doing something else odd that is causing asterisk to search for ‘*’