Voicemail stutters when called from another Asterisk Box

I am new to Asterisk and am testing a setup to replace international calling between our locations with calls over our VPN network.

One system is a Core 2 Due 2.4GHZ system running Ubuntu 9.04, the other is a VMWare Virtual Machine running Ubuntu 9.04. Both systems have 4 GB RAM assigned.

So far I have configured 2 asterisk systems, connected via IAX2. Calls are routing fine and call quality is perfect between the systems.

The issue I have run into is that when a call rolls to voicemail on the remote server, the voice is broken up and you cannot tell what it is saying. When I roll to voicemail on that system it plays just fine - it’s only when it is traversing the IAX trunk that I have the issue.

I am not sure where to go to diagnose the issue since it can only be duplicated when calling across the trunk.

Currently both systems are on the same Gigabit switch and same subnet.

Can anyone give me ideas of where to locate the root cause?

Are you running Asterisk I have a similar setup and notice the problem when calling into an IVR system. It worked fine prior to installing Here is a link to my original post.


I think we should open a bug on this if you are running the same version.


yes I am running My other boxes were until I noticed the new version out so I upgraded. One item I noticed with the upgrade is that the ZTDummy driver had issues during the install. Never noticed that with the install.

Since I am not using a Digium card I assume the ztdummy driver is what provides the timing for IAX2 connections. Based on that assumption I managed to get my trunk converted from IAX2 to SIP and the stuttered playback went away.

I can recreate the issue easily by switching back to the IAX2 trunk, I am curious to see if I get a Digium card, will the issue go away.

Are you using a Digium card?

No, I’m not using a digium card on any of my boxes. I must have missed the message about the dummy driver, but I wasn’t paying attention either. I didn’t install the dhahdi stuff either because I don’t have source code for my kernel. I tried to build it but it kept wanting a version of my kernel source that I don’t have. My kernel uses AES so I tried installing the right kernel sources but it still didn’t find them correctly. I really don’t want to use SIP, but I suppose I could if I have to.

I wonder what the error was? Maybe there is a simple fix for this. Does anyone know what the error is and what it means? I’ll try to build it on one of my boxes later and find out what the error is.

You shouldn’t be using zaptel drivers with I don’t know that it even supports them.