Choppy Voicemail/IVR

I’ve got an interesting problem. It seems like one that others have had, but there hasn’t been a clear solution or anything to the issue.

My IVR prompts are choppy. They’re better now than ever, but they still get this studdery quality, that’s especially aparrant on longer prompts, such as the echo test intro and the voicemail options. I’ve tried with Asterisk 1.2 on Trixbox, Asterisk 1.4 on Trixbox, and just recently i’ve rolled my own on Debian Etch with 1.4.9 and i’m still having the same issue.

Someone had said it was a CentOS issue, so i attempted to use Debian, but it does not seem to solve the issue at all. It’s just as bad as with my Trixbox 1.4.5 machine. I’ve checked ztdummy, i’m getting between 99.97% and 99.93% accuracy on one machine, and 100% and 83.71% on the other.

i’ve disabled acpi, tried turning off HT. They’re not being run in virtual machines, they’re 3.0Ghz P4’s with 1GB ram. Broadcom gigabit ethernet connected with 3’ of cable into a 10/100 switch, which is plugged into a phone with another 3’ cable. I’ve tried my linksys phones, snom phones, grandstream phone, they all have the same issue, so i’m fairly sure it’s not a device, more than likely the box itself. i’ve attempted swapping out the ulaw files for gsm ones, i have the same problem, the voice just sounds a bit different. The system doesn’t appear to be loaded down, and there are no analog cards onboard (we’re using a gateway) the calls out and in are as good as they’re going to be with a grandstream SIP gateway, but they don’t seem to have that issue… if they do, it’s lost in the bad quality of the gateway’s audio itself.

Anyone have any suggestions on what to try next? seems like i’ve done everything.

hmm, i’ve had problems like these before but they have always been due to bandwidth issues.

have you tried turning off the Firewall for a couple of seconds and testing to see if you till have jitter problems?

also, try a different codec, you didn’t specify what codec you’re using.

good luck

I don’t use a firewall, the machines are connected through a plain 10/100 switch… unless Debian Etch or CentOS comes default with a firewall enabled…

I’ve tried forcing phones to use the GSM codec, right now by default they use ulaw, but even with GSM i experience the same choppyness, with or without GSM sound files available to asterisk.

Could it be that : ?

gcc -v reveals
gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

So, most likely not the compiler.

sorry to raise this thread from the dead… BUT:

That’s my post above which is failrly similar to this. One thing i noticed you have in common is the BROADCOM ethernet card…

Heh, thanks for the insight. I’ll try to remember it. That system has long since parted from me, it was at my old work as a helpdesk system.

You have a good point though, since all I had available to me was current dell systems, they all use the Broadcom 440x network interface. Could have tried it on an older GX240 or something with an Intel interface instead.

you mentioned above about zttest scors.

Can you let me know if both sets of scros produced poor results?

I’m waiting for a x100p in the post which hopefully should fix my problem. cheers