Voicemail stutters

Hi Guys,
First off, I’ve searched the forums already but I’m a VOIP and Asterisk noob and I’m not sure what to look for.

I’ve just installed asterisknow (looked easiest :smiley: ) and I’m using softphones on my network computers. Now the softphones register fine and all that, but I try to dial 6050, or 7000, and I can barely hear the voice recording on the other end…it’s jumpy/stuttery…can’t think of how to describe it except it’s like when you’re trying to listen to music on dial-up :stuck_out_tongue: . My network speed should be fine, and I’ve tried dialing it from two different machines and I’ve used two different softphones (Ekiga and Zoiper) but it’s still the same problem…I’m not runnig any other analog or digital devices, it’s a very simple setup.

This is probably a noob problem, but I have no idea at all, any help would be greatly appreciated. :cry:

no one? :frowning:

Hi JoshuaR ,

Not sue if I can help but what happens if you call softphone to softphone or musiconhold?

Are you using a wireless network? Do you have high speed full duplex network connections for access to the Asterisk server?

If you’re using wireless, forget it… it won’t work. You have to use a wired connection when using softphones.

I’m the only person around to test it, so I can’t try softphone to softphone. I don’t know the no. for music on hold if it’s set up by default, and if it’s not then I haven’t set it up… I’ll see if I can give it a test soon softohne to softphone.

That sucks…I didn’t know voip was so bandwidth intensive. :frowning:
(I am btw using wireless)
I’ll wire a machine straight into the switch and see if that does anything.

Thanks for the replies too :smiley:

Hi Dufus,

I would agree that a hard phone and a wired connections are always preferred if available but I frequently use a few wireless connections with Zopier and Cisco hard phones and it is very acceptable.

I would like discuss this; there are two scenarios I use frequently;

  1. Telstra NextG wireless connection through a wireless gateway to our corporate WAN as I am so far out of town (I work from the Brisbane office three days and the home office two days a week) I cannot get any wired solution.

In this setup I use a Cisco 7940 connected to the Brisbane Asterisk box via NextG we have Asterisk boxes in every offices all interconnected via our corporate WAN.

There is a delay with the NextG but honestly it works really well.

  1. When in the Brisbane office I frequently use the Zopier soft phone via an 80211b/G wireless connection and the results are really good.

A couple of things to note;

a. Our WAN does not go via the Internet
b. We have end to end QOS
c. The largest WAN link is 1MB
d. The smallest WAN link is 256K (had do some tuning for serialization on the small ones)
e. I always prefer wired if at all possible.

The problem with wireless connections is that you don’t have the bandwidth dedicated to yourself. It’s essentially a hub, and is subject to incredible amounts of lag, jitter, and collisions. UDP traffic, (which is what you have with the RTP traffic) will suffer terribly.

It can be made to work. But only if you are the sole user of the wireless access point. I would also refrain from doing anything with your PC (such as browsing or checking email).

You will have luck with it sometimes, but it will be subject to serious interruptions when others are using the access point. I would not count on it being reliable.

There’s a reason why the voip wifi handsets are not selling well. Wifi is just not designed for voice.

Hi Dufus,

Yes I would generally agree with your comments; check these links quite interesting.

Is Your WLAN Ready for Voice?
cisco.com/en/US/solutions/co … 72e80.html

Cisco Voice-Ready Wireless
cisco.com/en/US/solutions/ns … 37071.html

Design Principles for Voice Over WLAN
cisco.com/en/US/solutions/co … f1a46.html

Cisco case study
cisco.com/web/about/ciscoita … _print.pdf

Interesting reading.

However, I’m sure that you recognize that the vast majority of business or home wi-fi users do not own an 802.11e access point.

802.11b/G routers are not designed to provide the QOS protections that voip calls require.

I’m 99% certain that the difficulties JoshuaR is having are related to his use of a wi-fi connection. Stuttering audio is almost always network related, and could either be infrastructure (as I believe it is in this case) or network traffic/congestion.

Hi Guys,
Here’s what I’ve done, first I added more memory to my machine, it wasn’t great specs, but with only me using it at the moment I figured it wasn’t too resource intensive :stuck_out_tongue: . That didn’t work. :cry:

So I tried a machine that was wired and not wireless, and it still stuttered when calling 7000 or 6050.

Just a min ago I tried calling another machine (wireless), and when I talk to a friend using zoiper (on same network still–just to clarify), it doesn’t stutter even with wireless.

It looks like it only stutters when I’m contacting the server :question: Not sure what to do or what could be causing it…

Looks like low CPU power, stop zaptel service (if not need it).

An easy test would be to plug your notebook with a soft phone into your wireless router. Most of theones I have seen have at least some wired ports. Does the problem go away?

It sounds like you tried that and in some cases it did help, I suspect the codec thing below might help you.

I have had some odd stuttering issues on a wired network with hard phones.

The things I did to resolve them included:

  1. Forcing everything to use ulaw. To do this, I forced all of the phones profiles into ulaw. In iax.conf nad sip.conf only allow ulaw, remove all other file formats in /var/lib/asterisk/sounds and /var/lib/asterisk/moh.

  2. Clean up modules.conf to only load things you use. This also gets rid of a lot of console noise for configuration errors on stuff you don’t use. Make asterisk as low profile an app as you can.

  3. Clean up Linux. I start with the CentOS single disk server (form the 4.X series) and then start cutting. My init.d only has a handful of necessary things in it. I use rpm -qf and see what package owns an init.d script, then do some research on the package, and decide weatehr i want to keep it or not.

I have found I can run Asterisk on really modest hardware like this.

One thing that strikes me as odd is I often get a bit of a stutter on the very first sylable of the IVR on a bunch of systems This is not bad and you really have to listen to even notice it. What is odd, is I have one test system that is running on an old PII/300 and that one does not stutter at all.

Hi guys:

Just a suggestion. When debugging rtp timing issues it may be better to use something like wireshark to record the packets and actually see where the problem lies. I am running asterisk on a server that is linked to my lan with a wireless connection. If I call in from another machine using a softphone, pre-recorded passages, such as the voicemail operator, are choppy. Music on hold is sometimes choppy. I use wireshark on the softphone machine to record the packet stream and then analyse the packet stream (click on an rtp packet, then statistics->rtp->stream analysis). Look at the column marked “delta” for the section of the stream where the choppiness occurs. The packets should be ~20 ms apart as each packet contains 20 ms of audio. What I find is that occasionally several packets in a row will arrive only a few milliseconds apart. Your softphone (or whatever phone) cannot deal with this as more audio is coming so it must drop those 20 ms audio sections. Choppiness with missing bits of the recording occur. At least that is the way I understand it.

So my problem, at least, is not that the network is too slow or congested. The problem is with rtp packet timing coming out of asterisk and the server. The packets coming from pre-recorded material come too fast, not too slow. I suspect audio choppiness is often caused by this.

I don’t deny that network problems can cause delays that will distort rtp data streams. But it might be best to actually check before jumping to conclusions.

I can cure my problem by using ztdummy. But I need to use my zaptel card for connection to PTSN. And with zaptel loaded I get bad timing and choppy audio on pre-recorded material. SIP connections and connections to PSTN are fine (asterisk cannot resend incoming audio out faster than it is received! :smile:). I just put up with the choppiness and hope that some day asterisk will integrate better with my network driver to send rtp packets properly.