Voicemail serveremail not working


#1

here is my voicemail.conf

[general]
format=wav49|gsm|wav
attach=yes
maxmsg=100
maxmessage=180
minmessage=3
skipms=3000
maxsilence=10
silencethreshold=128
maxlogins=3

emailsubject=[PBX]: New message ${VM_MSGNUM} in mailbox ${VM_MAILBOX}
emailbody=Dear ${VM_NAME}:\n\n\tjust wanted to let you know you were just left a ${VM_DUR} long message (number ${VM_MSGNUM})$
emaildateformat=%A, %B %d, %Y at %r
sendvoicemail=yes ; Context to Send voicemail from [option 5 from the advanced menu]
; if not listed, sending messages from inside voicemail will not be
; permitted
nextaftercmd=yes ; Skips to the next message after hitting 7 or 9 to delete/save current message.
; [global option only at this time]
serveremail=bla@bla.com

[zonemessages]
eastern=America/New_York|‘vm-received’ Q ‘digits/at’ IMp
central=America/Chicago|‘vm-received’ Q ‘digits/at’ IMp
central24=America/Chicago|‘vm-received’ q ‘digits/at’ H N 'hours’
military=Zulu|‘vm-received’ q ‘digits/at’ H N ‘hours’ ‘phonetic/z_p’

[default]
serveremail=bla@bla.com
3006 => 111,justin,techs@myemail.com
3003 => 111,clay
3004 => 111,greg
3005 => 111,devin

In the sendmail log I see the mail trying to go out but the from address is root or root@localhost.localdomain

I can’t get it to be anything except that …

ideas?


#2

Instead of using serveremail=email I changed the mta to include -f email

works


#3

in our server, it is under the ‘general’ context. And it’s working fine…