Voicemail notifications date is always 01/01/19 01:00[fixed]

I use an asterisk 1.8.1 on UBUNTU 10.10.
Recently I configured voicemails. No particular problem except that all the notification emails sent by asterisk are timestamped 01/01/1970 01:00.
In fact, if I restart asterisk, The first (sometimes the 2nd also) has a good timestamp. But following notification emails have 01/01/1970 as date.
Has anybody some idea to help me?

Thanks a lot


In the voicemail.conf, I had set “charset” and “locale” parameter to “fr_FR.UTF-8” as it seems to be the settings in my ubuntu server. Since I comment them, using the default value, and rebooted my asterisk, all went back right.
So I think that I have misunderstanding between my asterisk configuration and my ubuntu system.
I have to investigate.

That date is the beginning of time for Posix systems, depending on your timezone.

There is a bug in Asterisk that it sends email date headers in localised format, when they should always be in a canonical format, using US English month names. This was fixed sufficiently recently, that it might not be released versions.